Did my HD just die?

Discussion in 'Mac Basics and Help' started by cemorris, May 16, 2005.

  1. cemorris macrumors regular

    Oct 13, 2004
    I wast just installing Tiger on my 1.25 15" powerbook with 1 gig memory and 80 gig Hitachi drive. I made it through the install with out a problem which I did an erase and install.

    When the OS was up, I first used the Backup app to restore my files from my external USB HD. Everything went fine and I was able to use safari, mail and iTunes with no problems. I then installed iLife 05 which went without a problem. I opened iPhoto to verify my photos were restored successfully without a problem and all was well. I then went to install Quicken 2005 which I have stored on my external HD. The installer hung and I got an infinite beachball. I left it like that for 1/2 hour but nothing.

    I then did a hard reset ctrl + apple + power button. It rebooted but then went into beach ball when my user account was loaded and I waited for about 10 minutes before holding down the power key to shut it down. I then decided to zap pram but it did not work as it only made it to the same point with the same results.

    I then went to re-install tiger but my hard drive no longer shows up under the select destination. So I went into disk utility and it sees the drive just fine. I then went to format it and I get a failure with Input/Output error.

    I am currently doing a format with write all 0's option to see if I get a different error.

    After this I guess it is on to single user mode to see what I can see in there.

    Any suggestions?? Do I need a new HD? :confused:
  2. PlaceofDis macrumors Core

    Jan 6, 2004
    doesnt sound like a bad hard drive just yet. seems like something else happened to the OS install, definitely try wiping the drive clean and re installing. im sure others will have some better suggestions too
  3. cemorris thread starter macrumors regular

    Oct 13, 2004
    OK this is crazy. I tried doing a format with write all 0's and it tells me Input/Output failure and it cannot format. At this point I am certain it is the HD. So for grins I boot into single user mode and run fsck -f and no errors. So I then try to boot into the OS again and lo and behold, everything is fine! I am blown away. Some magic. To be safe I ran the latest version of Yasu and did all the repairs, cache clears and update prebinding. So far so good. I guess I will just backup more often and keep my fingers crossed.

    Thanks for the help.
  4. PlaceofDis macrumors Core

    Jan 6, 2004
    just to be sure, open up disk utility and check the S.M.A.R.T. status of the drive, it should warn you if it is failing, and yes, backupging your stuff is always a must
  5. cemorris thread starter macrumors regular

    Oct 13, 2004
    Thanks for the tip. SMART says "verified" which I am assuming it is ok. I was not aware of the SMART info.
  6. PlaceofDis macrumors Core

    Jan 6, 2004
    if its verified then there is no problem mechanically, could have just been some screwed up data i guess
  7. IJ Reilly macrumors P6

    IJ Reilly

    Jul 16, 2002
    The lesson: Start with fsck instead of ending there. Better yet, install and run AppleJack.

Share This Page