Did Parallels take a bunch of my SSD space?

Discussion in 'Mac Apps and Mac App Store' started by gusmahler, Jun 22, 2012.

  1. gusmahler macrumors member

    Joined:
    Mar 17, 2011
    #1
    I don't understand where my free space on my SSD has gone. I bought a 120 GB SSD to be my boot drive. I got a notice in Word that I was running low on space. I go to Finder and it says that I have 111.19 GB used, 8.5 GB free.

    So I run Omni Disksweeper. It calculates GB differently than OS X does, but the data gibes--111.5 GB total, 7.9 GB free, 103.3 GB used.

    But then I "sweep" the drive, which analyzes each of the folders to tell me how much space each is using. But this sweep says that I'm only using 64.7 GB of space. So where is the missing 38.6 GB?

    The only thing I can think of is that Parallels took up that space and Omni Disksweeper can't read that portion of the SSD. The odd thing is that I cloned the SSD from my old boot drive and Parallels doesn't even run (I just tried to run Parallels for the first time since I got my SSD). If it is Parallels, how can I recover that space?
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
  3. gusmahler thread starter macrumors member

    Joined:
    Mar 17, 2011
    #3
    I've used both OmniDisksweeper and Disk Inventory X.

    Both say that I have 8.5 GB free and 102.9 GB used. But when I click on the disk to find out what's taking up space, Disk Inventory X says I'm only using 68.9 GB. OmniDiskSweeper says I'm using 64.1 GB. The 4.7 GB difference between the two programs is odd. But much more important is the fact that Disk Inventory X can't tell me where 34 GB is. And Omni can't tell me where 35.6 GB is.

    Here's what Disk Inventory X says:

    [​IMG]

    Here's what Omni says:

    [​IMG]

    I can't figure out why the "Used" figure doesn't match the data when I click on the drive.
     
  4. brilliantthings macrumors 6502

    Joined:
    Feb 13, 2011
    #4
    Yeah. I had the same problem. Go into Configure in Parallels to configure virtual machine settings (the virtual machine can't be running while configuring). There you can change space used by virtual machine and also compress the drive, which can free up gigabytes of space. Give it a try.
     
  5. gusmahler thread starter macrumors member

    Joined:
    Mar 17, 2011
    #5
    I was an idiot and uninstalled Parallels before removing the Virtual machine. I just tried reinstalling Parallels, and it doesn't even see the Virtual machine.

    Am I SOL? If so, this really sucks. I have a 120 GB SSD that's almost "full" because of a bunch of space I can't access and can't delete and can't even view. Looks like I'm headed towards having to do a complete reinstall just so I can use the SSD. This sucks.
     
  6. dakwar macrumors 6502

    Joined:
    Nov 2, 2010
    #6
    Unless you changed the defaults when you were first installing, Parallels installs itself under /Applications and should be only about 150 MB. The virtual machines that parallels creates are under /Users/{your name}/Documents/Parallels and can be many many GB in size. When you uninstalled Parallels, you probably didn't delete the virtual machines. Go into /Users/{your name}/Documents/Parallels and see what is there and how large a file they are. Then, if you don't need them, just delete the entire folder "Parallels" in /Users/{your name}/Documents and empty your trash. This probably won't account for your missing 34 GB but its a start.
     
  7. jonnyz macrumors newbie

    Joined:
    May 28, 2008
    #7
    IIRC, Parallels VMs should reside in /Users/yourname/Documents/Parallels, so check there for any VMs. If nothing is there, you may have changed the location that Parallels stores VMs when you previously had it installed.

    As for finding your lost space, I would also give the WhatSize trial (http://www.macupdate.com/app/mac/13006/whatsize) a try before you give up. It has always worked well for me.
     
  8. NMF macrumors 6502a

    NMF

    Joined:
    Oct 27, 2011
    #8
    Just manually delete the VM.
     
  9. gusmahler, Jul 26, 2012
    Last edited: Jul 26, 2012

    gusmahler thread starter macrumors member

    Joined:
    Mar 17, 2011
    #9
    How? If I knew how to delete the VM, I would have just done that.

    ----------

    According to DiskInventoryX, the Parallels folder takes up 0 bytes. I deleted it anyway. No change in my free space.

    ----------

    It can't read more than 20 GB. Anyway, it seems very similar to Disk Inventory X and Omni Disk Sweeper, neither of which can tell me where the missing space is.

    Again, here is what Disk Inventory X says today:
    [​IMG]

    It says on one screen that I'm using 108.9 GB of space. But the graphical window only says I'm using 68.4 GB of space. 40.5 GB is missing and I'm constantly running out of space on my 120 GB SSD. I only got the 120 GB version because I had thought (from running Disk Inventory X prior to purchasing it) that I only needed around 60 GB of space. Had I known that I was actually using 108.9 GB of space, I would have saved up for the 240 GB version instead.
     
  10. gusmahler thread starter macrumors member

    Joined:
    Mar 17, 2011
    #10
    Finally found out that to delete a virtual machine, you need to find a PVM file. I searched for PVM files, and only found them on old backups. They do not exist on my current boot drive or my backup of the boot drive.

    So now I am completely lost. I got a low disk space warning again today and I'm just going to stop using the SSD. I have a backup on a much larger hard drive, so I won't be running out of space on it. I seriously doubt anyone here can help after all this time, so I guess I'll be selling the SSD after wiping it.
     
  11. gusmahler thread starter macrumors member

    Joined:
    Mar 17, 2011
    #11
    Another user PMd me and told me about Grand Perspective, another app that gives a graphical display of disk space usage. It didn't solve my problem, but at least it acknowledged it:

    [​IMG]

    It's the first program that tells me that there is 40 GB missing, though it doesn't tell me how or why. But at least that's a start.

    Now if I could only find out what "Miscellaneous used space" means?
     
  12. gusmahler, Aug 1, 2012
    Last edited: Aug 1, 2012

    gusmahler thread starter macrumors member

    Joined:
    Mar 17, 2011
    #12
    Wow, the solution seems so simple in retrospect. Turns out that Disk Inventory X, Grand Perspective, and OmniDiskSweeper can't read user directories, even if you run the program in an Administrator account. I finally came across a suggestion to run GrandPerspective as root and I found the problem--user files.

    When my son was back from college, he loaded a bunch of music onto iTunes. Of course, iTunes defaults to loading music in the User folder, which is on the SSD. So he loaded his entire ~40GB library of music from his iPhone. And I can't see those files, even from the Administrator account. It was only running as root was I able to see all those files. I logged onto his account and found all those files.

    Now, all I have to do is find out how to move all his music to the hard drive without affecting his iTunes. Luckily, he's back at college, so I have plenty of time to figure this out.
     
  13. bk0908 macrumors newbie

    Joined:
    Oct 24, 2014
    #13
    find residual files of VM

    what I did was,

    #sudo find / -name "*corp-vm*" (where corp-vm was part of my VM name)

    this returned a bunch of files which I then deleted with rm command,

    once this was done, OS reclaimed needed space.
     

Share This Page