Didn't see a search so....

Discussion in 'Apple Watch' started by jthesssin, Jun 1, 2015.

  1. jthesssin macrumors regular

    jthesssin

    Joined:
    May 6, 2013
    Location:
    Matthews NC
    #1
    Has anyone used an ultra sonic jewelry cleaner on the Watch?
    I will be using this for exercise and don't really want to change bands daily (I know I didn't think ahead). I would like the ability to drop her into one of those little ultrasonic baths to clean up the sweat and what-not. I know the watch is rated for sweating and rain but would ultrasonic vibrations allow water to seep in easier? Also, I may be blind, but where is the "Search This Forum" button????
    42MM Space Black Link bracelet
     
  2. jmh286 macrumors member

    jmh286

    Joined:
    Apr 22, 2015
    #2
    I remember someone a few weeks ago had said they tried this, and it killed the watch. The bands should be ok.
     
  3. timize macrumors regular

    timize

    Joined:
    Aug 13, 2010
    Location:
    Columbus, Ohio
    #3
    I would NOT place the actual watch in an ultrasonic cleaner. If you have a metal band (like the Milanese), the band itself should benefit from the cleaning. Just don't submerge the watch.
     
  4. ardchoille50 macrumors 68020

    Joined:
    Feb 6, 2014
    #4
    At the top right of the page there is a magnifying glass below your user name. Tap that magnifying glass icon and then tap the gear that replaces it, this will give you some search options.
     
  5. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
  6. jthesssin thread starter macrumors regular

    jthesssin

    Joined:
    May 6, 2013
    Location:
    Matthews NC
    #6
    Yeah i found that like 12 seconds after posting :) you gotta love it :)
     
  7. ideal.dreams macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    OH
    #7
    Yeah so as said, there was someone here that did try this before doing any research and if I recall correctly, it killed the "activate on wrist-raise" feature, likely due to damage to the accelerometer/gyroscope as a result of the ultrasonic cleaning. Nice of them to share their results though, to prevent anyone else from making the same mistake :)
     

Share This Page