Difference between iFaith & Redsn0w?

Discussion in 'Jailbreaks and iOS Hacks' started by krayziekray, May 19, 2012.

  1. krayziekray macrumors 6502

    Joined:
    Sep 24, 2008
    Location:
    127.0.0.1
    #1
    Hey, wow it feels good to be back on MacRumors, seems like forever since I was here last ...

    I have been trying to get back to iOS 5.0.1 for an unteathered jailbreak for quite sometime but kept on getting Error (1) or Error (1600) during my restore process on Mac OS X when using Redsn0w to stitch my SHSH blobs and build a custom ipsw.

    Having limited trust in Windows, I decided never to give it a try on here. Nevertheless this morning I thought "what have I got to loose?". So, I booted into windows and downloaded Redsn0w. After stitching and building the ipsw file, I tried a restore and nothing ... same as before, error after error.

    After some googleing around i saw iFaith and how everyone was able to downgrade with this software. Now I want to point out at this stage I have always used Redsn0w and everything from the iPhone Dev Team for all my JB needs. So I was abit hesitant to try it. However, I thought I'd give it a shot.

    First time round ... Done, I have successfully managed to downgrade to 5.0.1 and should be able to unteather jailbreak soon enough.

    My question is this ... What is the difference between the way iFaith stitched the SHSH blobs and Redsn0w that lead only the iFaith custom ipsw to work for me? Is it something I was doing wrong in Redsn0w?

    I have always used and trusted everything from the iPhone Dev Team. Is there anything I should be concerned about that iFaith may have done to the ipsw to compromise my security? I know I'm being a bit pessimistic, but I just want to know why one software worked for me and Redsn0w didnt baring in mind I have always used Redsn0w and never had an issue. Was I doing something wrong on Redsn0w?

    Thanks,
    KrayzieKray
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    IFaith has been unique in that it could grab your hash files from the firmware currently on your iDevice (A4 processors and older).
    Redsn0w restores have required the use of hashes saved while Apple was signing each firmware version.
    Redsn0w sometimes has issues with some PC's (great on Macs).
    Sn0wbreese runs fine on PC since that is it's only platform.
    Sn0wbreeze will not yet work on A5 devices as Redsn0w does.
     
  3. krayziekray thread starter macrumors 6502

    Joined:
    Sep 24, 2008
    Location:
    127.0.0.1
    #3
    Thanks for the update :)

    I've just got my 5.0.1 jailbreak back using Redsn0w (turns out I just needed to create a no bb ipsw before stitching my SHSH blob) :D

    Is there any reason why Cydia doesn't have my 5.1 SHSH files on store? I thought Cydia would pull down all SHSH blobs from apple when they were available?
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Every time there's a new firmware release use Tinyumbrella to pull your blobs to make sure you have them locally. It also uploads them to cydia.
    Sometimes the list on cydia is so long by the time millions of iphones blobs are requested and saved by Saurik Apple releases another iOS update. And those requests by Cydia are done some at a time in order not to get his server blacklisted by requesting so many blobs at a time from Apples servers.
     
  5. krayziekray thread starter macrumors 6502

    Joined:
    Sep 24, 2008
    Location:
    127.0.0.1
    #5
    Sweet, thanks :) Yep, I just thought I'd better pull down the 5.1.1 ones manually but was hoping they would be uploaded to Cydia incase my laptop fails on me one day :) ... thanks for clearing that up
     
  6. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #6
    In the past after using TU to save my blobs locally I've used the iSHSHIT utility from cydia to email the blobs to my email account. Of course after saving them locally with TU you could easily just email the files to yourself. I preferred iSHSHIT because I could use it on the go. However I think iSHSHIT gets updated a little bit slower than TU so keep that in mind of you decide to use this utility.
     

Share This Page