Different 128GB Limit behaviour of different brands on AGP G4

Discussion in 'PowerPC Macs' started by Cox Orange, Jan 27, 2013.

  1. Cox Orange macrumors 68000

    Joined:
    Jan 1, 2010
    #1
    Hello,

    I recently formatted a WD1600AAJB and a Seagate ST3160021A in two partitions (1. 127GB, 2. the rest).
    To format the drives I had to connect it to a IDE/SATA-PCI Card (XRack SUA100e, also sold as Macsense, recognized as SCSI-Card - only worked for the WD) and in a second test I used an external Firewire400 enclosure (worked for WD and Seagate Drive).

    Now what puzzled me:
    1. connected to the onboard ATA Controller of a PowerMac G4 AGP the WD was recognized/shown as two drives on the desktop (Disc Utility and SMART Utility also showed two drives). The same for the PCI-Card.
    I tried backing up my OS via SuperDuper! to the first 127GB, but SuperDuper always stopped gaving error reports at different progression states. It did it, when I put it in an external FW-case, too. It did it, when I formatted the drive back to 149GB (160GB), so the drive seemed to be defective, though SMART was ok in every SMART-parameter. I now RMAed the drive.
    2. the Seagate could be formatted only in the ext. FW case. No Jumper position (tested it, to be fool proof, I wasn't a fool in the end) etc. worked on the PCI-Card. I backed up my OS to the 127GB partition via FW and put OS 9 on the rest partition. Then I swapped the drive: the only controller that could see it was the onboard ATA-66 of the G4 itself, but of course it showed only the first 127GB. In contrast to the WD, it did not show the second partition. Disk Utility showed a second, but greyed out partition as 400MB. So again, the last 20GB of the WD was shown on desktop and disk utility.
    SMART utility does say it's 160GB, but doesn't show the second part of the Seagate, too (which it did with the WD).

    Does anyone have an explanation to it.
    A while back (some years), I asked WD and Hitachi, whether I could use a 160GB drive with only 128GB (I am always like, better check three times, before doing, even if the "net" says it works).
    WD said I could go ahead with a 160GB. Hitachi said I should better use a 123,5GB model, because the (164GB) drive could be damaged/corrupted or data could unwillingly be written in the sectors not recognized by the system after start up.

    I wonder why this is. Is it just one company trying to prevent themselves from every possibly failures and the other not caring that much or is it the technique used?
     

Share This Page