Different albums with same name listed as one album

Discussion in 'iPod touch' started by Evangelion, Mar 2, 2008.

  1. Evangelion macrumors 68040

    Joined:
    Jan 10, 2005
    #1
    I'm not 100% sure that should I post this in the iPod touch forum or here, since the problem manifests itself in my touch....

    I have a bunch of songs from ZZTop from their "Greatest Hits"-compilation. I have also bought Richard Marx's song "Hazard" from ITMS, and it's from his "Greatest Hits" compilation. Now, if I browse my songs in the touch by album, I only have one album called "Greatest Hits" listed, and that album contains songs from both ZZTop and Richard Marx. In iTunes's album-view those albums are listed separately like it should be.

    I have checked the settings in iTunes, and I have checked the "Part of a compilation" in both artist's songs, and the metadata (Artist, Album Artist etc.). What gives?
     
  2. theodor p macrumors newbie

    Joined:
    Jan 25, 2008
    #2
    what i did is change the album name from "Greatest Hits" to "Greatest Hits - (insert band name here)"

    seems to work pretty well, or you could change the info in the "sorting" pane of the get info window of the song.
     
  3. bsheridan macrumors 6502

    bsheridan

    Joined:
    Jan 11, 2008
    #3
    In itunes go to Get Info | Sorting | Sort Album. Then for ZZtop type ZZTop greatest hits, and likewise for the other album.
    This way both albums should appear as Greatest Hits but as 2 separate albums.
    You have to edit each song individually though to access the 'Sort Album' option.

    Good luck, B.
     
  4. Fuchal macrumors 68020

    Joined:
    Sep 30, 2003
    Location:
    Boston
    #4
    I think setting the "Album Artist" tag gets around this problem.
     
  5. losx12 macrumors member

    Joined:
    Aug 13, 2006
    #5
    You should uncheck "part of a compilation" off both albums. When you check it, it makes itunes think its one album with various artists which is not the case here.
     
  6. Evangelion thread starter macrumors 68040

    Joined:
    Jan 10, 2005
    #6
    That tag is already set like that

    I do have that box checked. I'll try unchecking it.

    EDIT: I unchecked the checkbox, and re-synced my touch, but it still lists those two albums as one :(
     
  7. John.B macrumors 601

    John.B

    Joined:
    Jan 15, 2008
    Location:
    Holocene Epoch
    #7
    I do this for sorting on my iPod. In iTunes (7.5) using Artist/Album works fine for me.
     
  8. chall5 macrumors regular

    Joined:
    Sep 19, 2007
    Location:
    UK
    #8
    I do this as well, its not ideal but solves the problem
     

Share This Page