Difficulties installing apps through installer? i.e. BSD Subsystem?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by tim370, Feb 25, 2008.

  1. tim370 macrumors newbie

    Joined:
    Sep 15, 2007
    #1
    This is just a quick note on how to fix installer problems which i came across yesterday with my new iPhone - it would say "Download failed" when trying to install BSD subsystem.

    I got a brand new 16gb iPhone which was only purchased a few weeks ago and brought over here to Aus by a mate.

    We both unlocked it using ziphone 2.4 together (on the same computer). But for some reason i couldn't install BSD Subsystem and he could.

    So i found instructions on a fix and they worked flawlessly so here it is for anyone in the same boat:

    1. Install 'Community Sources' - it had no troubles downloading and installing

    2. Go to 'Sources' - the tab down the bottom right corner when in Installer

    3. Hit 'Refresh' up in the top left corner

    4. Go to the update tab - you will see that there is a new update for community sources. Now make sure you press 'Update All' and not just press on community sources... i'm not sure why but apparently this makes a difference.

    5. Once the update has been done, you should be able to install BSD Subsystem and subsequently any other apps.


    I hope that helps - it took a while to track down last night and I couldn't find it again today at work so i just re-wrote it... i didn't figure any of this out myself and i'm not sure what else to do if this doesn't work.... it was just great for me so i thought i'd share the word :)
     
  2. nataraja macrumors newbie

    Joined:
    Feb 26, 2008
    #2
    not working ...

    hi tim370,

    thanks for your advices..
    But, this it not working for me...

    wen trying to download a app, the dl status bar doesn't go forward.... it just doing nothing ....

    any other help ??

    thanks
     
  3. CD3660 macrumors 68040

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #3
    I had this problem and only solved it by getting BSD Subsystem from a different source (one that isn't overwhelmed at the moment).

    Open Installer, then Sources, select edit then add and enter the following:

    hackthatphone.com/1.xml

    Once that is processed, install BSD from their repository. Worked first time for me!

    Let us know how you get on. :)
     
  4. bamaworks macrumors 6502

    Joined:
    Nov 9, 2007
    Location:
    Lexington, KY
    #4
    Server most have lost it's mind.... placed my post on the wrong topic...
     
  5. tim370 thread starter macrumors newbie

    Joined:
    Sep 15, 2007
    #5
    mate unfortunately i have no idea, im sure there are a few others that have experienced the same problems so just keep searching, but try what 'CD3660' said - its probably the best option so far
     

Share This Page