Difficulties installing Mavericks in Mac Pro 1,1

Discussion in 'OS X Mavericks (10.9)' started by Ted W, May 12, 2014.

  1. Ted W macrumors newbie

    Joined:
    May 12, 2014
    Location:
    VT
    #1
    Hi

    I am new here and to the Mac environment. I am trying to get into the Macs using an old Mac Pro 1,1 and Mac book Pro

    I have a really hard time trying to install Mavericks in my MP 1,1. I have been working on it for days but have been unable to get it going

    I followed the directions here

    www.reddit.com/r/apple/comments/···0062007/

    I created an install drive on a USB Flash drive. as in here

    I replaced the boot.efi on the USB drive in the 2 locations as mentioned in the above

    I then added my Board ID to the OSInstall.mpkg and InstallableMachine.plis [this was tricky for me. I ended up downloading Xcode and using Flat Package Editor for that]

    Initially my MacPro boot.efi file was locked and I was finally able to remove it using terminal with this command:

    sudo rm -f /System/Library/CoreServices/boot.efi

    I then replaced it with the downloaded boot.efi [After some failures to reboot]

    My Mac Pro got stuck several times [ Option-Command P-R ] would revive it most of the times. At some point it became unresponsive to anything I did and I had to remove the PRAM battery and place it back to unfreeze it.

    Now when I attempt to reboot it from the USB install drive it get stuck on

    ...Still waiting for root device

    The multiple operations prior to that warning seems to be going well. [see attached img]

    Now I can no longer boot up this computer the Restore option [Command + R] does not work [I am connected to the internet ] [I ordered OSX Lion 10.7 from Apple hoping to be able to do a clean install from it]

    What have I missed? How can I complete converting my mac pro to 64bits and Install Mavericks on it?

    Thanks so much! I am stuck.

    [...Now as if I did not have enough I want to replace the CPUs with a pair of Xeon Quad Core 5355 after I will be able to install Mavericks]
     

    Attached Files:

  2. Sko macrumors regular

    Sko

    Joined:
    Oct 17, 2009
    Location:
    Germany
    #2
    As I recall, this happens when the USB drive is not GUID partition type. Reformat and try to create an USB install with SFOTT.
     
  3. Ted W thread starter macrumors newbie

    Joined:
    May 12, 2014
    Location:
    VT
    #3
    One step forward

    Thanks so much Sko!

    I was able to move one step forward. Now I have difficulties editing the OSInstal.mpkg.

    I found the Flat Package Editor in Xcode auxiliary package from 7/2012. [ Could not find it in my Xcode package ]

    Now when I try to edit the Distribution file it removes it from the package even when I hit save and repeat save. When I move the OSInstall.mpkg to the desktop the Distribution text file is disappearing

    How should I edit this file? I do not understand its behaviors

    Thanks so much
     
  4. Sko, May 13, 2014
    Last edited: May 13, 2014

    Sko macrumors regular

    Sko

    Joined:
    Oct 17, 2009
    Location:
    Germany
    #4
    I never really tried myself, as I used SFOTT, but for curiosity's sake I've read through oemden's scripts to get an idea and ended up doing the following:

    - opening OSInstall.mpkg in FPE
    - moving 'Distribution' to the desktop
    - deleting 'Distribution' in FPE
    - editing 'Distribution' from desktop in TextEdit
    - moving 'Distribution' from desktop to FPE window
    - saving in FPE

    I checked and the edit stuck. Didn't test it though, as I changed a random 'true' to '1' only for tracking purpose.

    PS: Another benefit when using oemden's SFOTT is that TiamoMacProFix.pkg is included for free!
     
  5. Ted W thread starter macrumors newbie

    Joined:
    May 12, 2014
    Location:
    VT
    #5
    Thank you so much Sko!

    Stayed up till 2AM last night. It is a learning experience...

    The problem I have with using SFOTT Is that I crushed the installation of OSX 10.5 my MP had with my attempts to install 10.9. So I can not install from within the Mac Pro. I am using my Macbook to get the installation on the USB drive and edit it there.

    Now I am downloading OS 10.7.5 from the Apple store hoping to have it installed on my Mac Pro on one drive so I can then go directly to it and install the 10.9 on the main drive. The whole thing, as frustrating as it is, have been quite a learning experience to the Mac environment for my.

    It seems that the Mac have many internal none [clearly] documented pathways that I run into. Talking to you and reading other posts have been a tremendous help in figuring out that "secret" maze.

    Does the recent XCode have a Flat Package editor init and I just missed it? Where did you get the FPE you are using? Is there any other tool to edit the OSInstall.mpkg?

    BTW I have noticed that you upgraded your CPUs as I plan to do, did you have to change some firmware after that? What did you do for graphic card?

    Really want to thank you again, your help is truly exceptional and much appreciated

    Ted
     
  6. Sko macrumors regular

    Sko

    Joined:
    Oct 17, 2009
    Location:
    Germany
    #6
    Not that I know of, I grabbed the FPE from the Auxiliary Tools as you did.

    You don't exactly have to, but I feel better with matching software. And 'About this Mac' recognizes the CPU.

    My Radeon 4870 is an XFX-brand 1GB PC-card flashed with the original Apple-ROM for boot screen. But Nvidia cards seem to be the more popular choice nowadays, working ootb, without boot screen. See the discussions at netkas.org about flashing.
     

Share This Page