Digital Copy Trouble

Discussion in 'iPod' started by ukwildcat, Jan 7, 2010.

  1. ukwildcat macrumors 6502

    Nov 29, 2009
    Hi all,

    I searched the forums and could not find an answer, so here goes:

    I was transferring a digital copy of star trek to itunes and the process was interrupted. A message popped up saying to eject the disc, clean it, insert again and retry the transfer. I did this and everything worked fine, but now I have 2 copies of star trek in itunes. Only the first copy isn't really a copy, it just shows as the album artwork. I can't play the movie or do anything else for that matter, from the first artwork. I tried deleting the artwork, but I can't do anything. I can't drag it to the trash, or anywhere else. I am able to highlight the artwork and right click on it, but that is where it ends.

    How do I get rid of the extra movie artwork from itunes. Thanks for the help from a newbie.
  2. ukwildcat thread starter macrumors 6502

    Nov 29, 2009
    Never mind. I closed itunes and reopened and the extra artwork was gone.
  3. amitsnv macrumors newbie

    Jan 6, 2010

    In such cases its always beneficial for us to close and reopen and better to restart. In many cases the problem is solved by just restarting the itunes.

Share This Page