Digital Rebel Firmware Problems?

furryrabidbunny

macrumors 6502
Original poster
May 10, 2005
475
0
Mesa, AZ
Has anyone else here that uses the Digital Rebel noticed firmware problems? I can no longer shoot in RAW format, and none of my modes function properly (for example, I can no longer adjust the shutter speed in manual mode in the way the user guide explains). O yeah, I am running version 1.1.
 

wheezy

macrumors 65816
Apr 7, 2005
1,280
1
Alpine, UT
Uh oh, that's kinda wierd. When did they last update the firmware? When I bought my 300D from a co-worker in January he had done the most recent firmware update, but I haven't checked since. Did you try one of those 3rd party firmware hacks that are supposed to give you the same extra options the 10D had? Have you tried re-updating the firmware?
 

mkrishnan

Moderator emeritus
Jan 9, 2004
29,641
12
Grand Rapids, MI, USA
Is this a 300 or a 350? According to Canon's website, the firmware for the 300 hasn't been updated in a looong time -- not since 10/03. Link

I'd give re-flashing it a try and see what happens. Mine has not done the kinds of things you describe.
 

Westside guy

macrumors 603
Oct 15, 2003
5,397
2,226
The soggy side of the Pacific NW
The first question is - are you using Canon's firmware, or one of the "enhanced" firmware products available for the Digital Rebel from other folks?

The second question is - when you say you can't shoot in RAW, are you checking when you have the camera set to fully automatic mode? I noticed the (original) DR we have at work does not allow use of RAW unless you take it out of full auto mode.

Edit: Sorry for the partial dupe w/ wheezy's post.