Dimming Screen Annoyance

Discussion in 'MacBook Pro' started by bimmerchop, Sep 10, 2007.

  1. bimmerchop macrumors regular

    Joined:
    Aug 15, 2007
    #1
    Okay, help me out here guys. I've had my new mbp for about a month, but I can't figure out how to stop the screen from dimming on it's own. This is probably an easy fix but I'm a noob so go easy on me lol.

    I already went into my my energy saver preferences and checked off the box saying to automatically reduce the display brightness before display sleep... but every now and then, it still dims on its own if I don't use the computer for say 10-15 minutes. Am I missing something, is there another preference I need ot be looking for?
     
  2. siurpeeman macrumors 603

    siurpeeman

    Joined:
    Dec 2, 2006
    Location:
    the OC
    #2
    when going to the energy saver preferences, you have to uncheck the box that asks to automatically reduce brightness on the screen for both power adapter and battery profiles. it could be that you unchecked the box for the power adapter, and it's still dimming while you're on battery or vice versa. try that, and see if it works.
     

    Attached Files:

  3. bobcan macrumors 6502a

    bobcan

    Joined:
    Jan 8, 2007
    Location:
    Sunny but Cold.. Canada
    #4
    I think you are fighting....

    I think you are fighting an Uphill Battle here.... the Problem you have (not problem if you wanna save Power!!) is that most people wanna save power!! I think Apple has "Out Thunk You" in your quest...

    I too have been annoyed at times but got over it sooner than later... I've had a MBP since Apr-06 and what you have done is IT I think... Power Saver> Options> and cypher what you want from there... I think if the computer is not doing meaningful work it will DIM.... Oh well!! :rolleyes:
     
  4. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #5
    I'm impressed with how often this fails to follow the setting. I find my machine doing this again since 10.4.10 so hopefully, it will be repaired before Tiger receives its final update.
     
  5. bimmerchop thread starter macrumors regular

    Joined:
    Aug 15, 2007
    #6
    I have it unchecked for both the battery and power adapter. I'll try the pmset when I get home majordude. I don't have my mbp in front of me now so it will have to wait till I get home later on tonight.
     
  6. looking4anotebo macrumors 6502

    Joined:
    Jul 9, 2007
    #7
    This also bugs me quite a bit. It often dims on me 1-2 minutes after I last touched something.
     
  7. cardsdoc macrumors regular

    Joined:
    Jun 9, 2007
    Location:
    Shaker Hts, OH
    #8
    I have the same annoying issue. There are multiple threads on this and it seems to be an OS X bug. For me (and others as well), the setting sticks only until the MBP goes to sleep or reboots then you have to check and uncheck the setting again no matter what solution you try. If anyone has a developer copy of Leopard maybe they can report back on this issue.
     
  8. maestrocasa macrumors regular

    Joined:
    Aug 16, 2007
    Location:
    Somewhere on the Buffalo National River
    #9
    I'm also having similar problems with my week-old MBP. my problem is that the auto dimm is so fast and sensitive, if my hand casts a brief shadow on the right side of the machine (like when deleting), the screen dimms, then relights 1/2 a second later when my hand moves. (it's happened 3 or 4 times while writing this post)
     
  9. aquajet macrumors 68020

    Joined:
    Feb 12, 2005
    Location:
    VA
    #10
    This has been an issue for a long time now. It is annoying and hopefully it will be corrected at some point.
     
  10. klex macrumors regular

    Joined:
    Jun 28, 2007
    #11
    This is an issue with intel based macs. Apple has an article about here
    http://docs.info.apple.com/article.html?artnum=304092.

    The article reads:

    See the "note" at the bottom where it says
     
  11. bobcan macrumors 6502a

    bobcan

    Joined:
    Jan 8, 2007
    Location:
    Sunny but Cold.. Canada
    #12
    Yup.. me too....

    Me too... I don't know if my new SR is more sensitive to this Dimming Up/ Down but seems so from my Original 1.83 GHz MBP... :(

    I think it generally happens when ther are some "shadows" on Keyboard as there is (I think..) a Light Sensor under the Keys on the Upper Left and Right both ... near the esc & Eject Keys... If there is "even" light across it seems to be usually OK...
     
  12. xpovos macrumors 6502a

    xpovos

    Joined:
    Jun 7, 2007
    Location:
    Tennessee
    #13
    Actually, your issue is not the one the OP is describing. The OP's issue is a bug in OS X that doesn't retain the proper setting in Energy Saver across reboots. It's a software issue.

    Yours is a hardware issue, completely normal and due to the auto-dimming sensor being too sensitive. Shadows from your hands can trigger the sensor, dimming the display. If your hands move over the speaker grills quickly enough, the auto-dimming can even fool you into thinking you have a screen flicker defect.

    If this over-sensitivity of the sensor bothers you (as it does me and many others), it's an easy fix to just turn that feature off in the "Displays" pane in System Preferences.
     

Share This Page