Direct Ethernet connection between alu macbook + imac won't work

asphyxiafeeling

macrumors regular
Original poster
May 31, 2008
199
0
Cali baby!
Title pretty much sums it up.

I have an ethernet cable. i have an alu macbook. i have an iMac. i need to transfer files between the two.

tried connecting the ethernet cables.

on the macbook it says "ethernet cable not plugged in"

on the iMac it says "ethernet cable not plugged in".

i know the ethernet cable works because i brought my macbook up to my router and used the ethernet cable to connect to the internet. it is Cat5 or whatever.

i've tried everything static IP addresses. restarting. replugging. over and over and over. no luck. the macs just pretend there is no ethernet cable plugged in. tried DHCP. tried manually. but it works when i connect my macbook to my modem.

what am i doing wrong? please help me.

i'm frustrated beyond belief.

i've tried everything. i've googled, i've mroogled. nothing works. i spend two hours trying to work this out myself before coming here. every single webpage online just says "oh just turn on file sharing LOL then it works" not for me it doesn't. i've tried that. i've tried it over and over and over again. it doesn't work for me. still won't recognize.

i'd use wireless connection to transfer but that'd take like 20+ hours to send 60GB+ of data. too long (iMac is not at my house)

are ethernet cables just fail? this is a BRAND NEW 20 inch imac and a aluminum macbook from 2008.

so frustrated. GRAHHH.

has anyone else experienced this? does anybody know what i am doing wrong?

thanks.
 

MrCheeto

macrumors 68030
Nov 2, 2008
2,966
0
System Preferences>Sharing and make sure File Sharing is enabled and configure the permissions any way you like by clicking on "Options"
 

asphyxiafeeling

macrumors regular
Original poster
May 31, 2008
199
0
Cali baby!
System Preferences>Sharing and make sure File Sharing is enabled and configure the permissions any way you like by clicking on "Options"
thanks for the quick reply.

i have everything turned on except SMB (because that's for windows, right?).

still doesn't work.

the problem is just that neither mac even "sees" that the ethernet cable is plugged in. but if i plug it in to a router to test the cable, BING! connected to internet. so i know the cable works. the macs just refuse to recognize they are connected to eachother!

incredibly frustrating. at first i was just transferring the 60GB via wifi and was about to just leave my mac over for the night... but then a big windows friend of mine came over and said "1.5MB/s? SLOW. you should direct ethernet it'll be like 50MB/s i do it all the time with windows blahblahblah apple sucks ipods suck etc etc" went into the whole speech...

so i said, "OK fine gimmie an ethernet cable i'll figure this out E Z"

EMBARRASSING i can't make it work.

it must be something i'm doing wrong... i just can't figure out what!
 

samh

macrumors 6502
Oct 29, 2009
317
3
Someone can correct me if I'm wrong, but unless Mac's have an auto-crossover feature you will need a special cable to do what you're doing.

In a standard ethernet patch cable, the 8 internal wires are the same at each connector. Pin 1 = Pin 1, Pin 2 = Pin 2, etc. That means when you plug two computers directly with a cable like this, they are both sending on the same pin and receiving on the same pin which obviously won't work.

A crossover cable reverses certain pins at one end, to do just the sort of thing you envision (or to connect certain types of networking equipment together).
 

MrCheeto

macrumors 68030
Nov 2, 2008
2,966
0
Samh: Macs use regular ethernet cables for crossover connections.

OK, go into System Preferences>Sharing and enable Internet Sharing. Share your connection from Airport and To computers using Ethernet. It will take effect in about 5 minutes.
 

asphyxiafeeling

macrumors regular
Original poster
May 31, 2008
199
0
Cali baby!
Someone can correct me if I'm wrong, but unless Mac's have an auto-crossover feature you will need a special cable to do what you're doing.

In a standard ethernet patch cable, the 8 internal wires are the same at each connector. Pin 1 = Pin 1, Pin 2 = Pin 2, etc. That means when you plug two computers directly with a cable like this, they are both sending on the same pin and receiving on the same pin which obviously won't work.

A crossover cable reverses certain pins at one end, to do just the sort of thing you envision (or to connect certain types of networking equipment together).
that's what i originally thought... but all the posts i found via google / mroogle said that any mac made within the last 8 years should have no problem making the transfer using standard ethernet cables because of something called Auto-MDIX...

but then again i could have NO idea what i'm talking about (hence i'm asking for help) :confused::mad:
 

crazzyeddie

macrumors 68030
Dec 7, 2002
2,790
0
Florida, USA
Macs do have the auto-crossover. Have for years. I've gotten this to work on many computers. Used it last week in fact to do Migration Assistant. This is one of the methods that Apple recommends if you don't have Firewire.

Perhaps the cable you're using has some bad wires. It would still connect to your router at a slower speed, but might be causing the two computers to fail communicating to each other.
 

asphyxiafeeling

macrumors regular
Original poster
May 31, 2008
199
0
Cali baby!
Samh: Macs use regular ethernet cables for crossover connections.

OK, go into System Preferences>Sharing and enable Internet Sharing. Share your connection from Airport and To computers using Ethernet. It will take effect in about 5 minutes.
done and done. i did that to both iMac and Macbook. plugged in ethernet cables.

still no luck! it just refused to recognize the cables. it just says "ethernet cable is not plugged in"

what should i set the configuration to under ethernet? DHCP? manually?

starting to believe that maybe the cable just doesn't work. :/

worst comes to worst, i'm going to borrow an external HD from a friend, copy the files in my spare time (taking a day or so) then going over and transferring to the iMac (taking another day). so things will still be ok if this doesn't work... but! you know. i'd rather figure it all out.
 

MrCheeto

macrumors 68030
Nov 2, 2008
2,966
0
Here's what I dug up

Alright,
here we go:

* Connect both Mac, using a standard network cable

Mac #1:
* Open up System Preferences > Network
* Choose Ethernet, and select Manually instead of Using DHCP.
* Set the IP address to 192.168.0.1, Subnet Mask to 255.255.255.0

Mac #2:
* Same as above, IP address 192.168.0.2

Now you should see the other Mac in the Finder sidebar. As said before, use the Public folder on each Mac to share files and folders.


This should do it, tell me if you need more help.

/Rupert
 

asphyxiafeeling

macrumors regular
Original poster
May 31, 2008
199
0
Cali baby!
Here's what I dug up

tried it, many many times. that was one of the first posts i found via google. i put it that info and hit apply. it just sits there. is it somehow still connected even if the ethernet cable on the left hand site of the network settings page still says "not connected"?
 

MrCheeto

macrumors 68030
Nov 2, 2008
2,966
0
Nope, give me a minute and I'll get my old iMac G3 running. I used to transfer files through the Internet Sharing feature because it didn't have airport so I bridged the connection, made for hella fast transfers even though it's only 10/100 ethernet :p

pending.
 

asphyxiafeeling

macrumors regular
Original poster
May 31, 2008
199
0
Cali baby!
Nope, give me a minute and I'll get my old iMac G3 running. I used to transfer files through the Internet Sharing feature because it didn't have airport so I bridged the connection, made for hella fast transfers even though it's only 10/100 ethernet :p

pending.
thanks. let me know how it goes. decided to go home tonight (it's almost 5 am where i live, haha) but i made a promise to my friend i'd figure this out and eventually come over to transfer files.

can't let that windows friend get the last laugh on the ethernet. at the end of his little anti-apple speech he started trying to get into why the blackberry app store is 100x better then the apple app store, and the whole apple's hardware is inferior to PC hardware for the $$ etc etc ughhhh annoying discussion as you can imagine.

tomorrow i'm going to go over and try again with one of MY ethernet cables, to make sure it's not just his one. i WILL figure this out.

i'll keep ya'll updated! :)
 

MrCheeto

macrumors 68030
Nov 2, 2008
2,966
0
Here's my exact experience:

1 White MacBook from 2008
1 MacBook pro from 2009
1 Cat 5 cable

Airport turned OFF on both.

Ethernet-
configure IPv4: Using DHCP

It will say "Self-Assigned IP" after 10 seconds. If it says "not connected" then something's wrong.

After that I go into the Finder and there should be a list of Shared devices, one including the opposite mac. Under the Shared I selected the MacBook and selected the Public folder, typed in the information for the MacBook user and was able to copy files onto the MacBook Pro. The exact same was true the other way around.

1. You must enter the user information for the computer you're trying to access.
2. You cannot, for some reason, connect via Network in Finder, you MUST access the opposite mac by using the Shared tab in the sidebar.
3. Internet Sharing does not need to be activated but File Sharing does (duh :p)

As a matter of fact I moved this image from the MacBook onto my MacBook Pro using only ethernet ;)

 

monokakata

macrumors 68000
May 8, 2008
1,886
396
Hilo, Hawai'i
I feel certain you're having a cable issue.

I just connected my MBP to my Mac Pro, directly, via non-crossover cable. I let the Mac Pro assign a self-assigned IP address to the ethernet port, and then I manually assigned an address on the MBP.

You seem to know this part already, but:

Mac Pro self-assigned to 169.254.107.81
so I set MBP to 169.254.107.82

Yours will probably self-assign to different IP addresses, but that's unimportant. Worked fine. Each machine came up immediately in the other's finder, under Shared.

So I really think you've got a cable problem -- perhaps a connector problem. I hear you about plugging into the router, but you wouldn't be the first person with a cable that worked OK on one set of connections, but didn't work right on the other. Rare, yeah, but it does happen.

Get another cable. You don't need a cross-over cable, as others have said.

You say you connected to a router. Did you confirm that both the iMac and the MBP can connect to the router? In other words, you want to confirm that both ethernet ports (physical) can connect properly to that cable.
 

MrCheeto

macrumors 68030
Nov 2, 2008
2,966
0
Check this out, a new Airport update was recently released and lists a fix for this:

"• Inability to create a computer-to-computer network, or share the Internet connection on some MacBook, MacBook Pro, and Mac mini computers"

If you're running 10.6 that could have been the problem ;)
 

samh

macrumors 6502
Oct 29, 2009
317
3
I have an ethernet cable. i have an alu macbook. i have an iMac. i need to transfer files between the two.

tried connecting the ethernet cables.

on the macbook it says "ethernet cable not plugged in"

on the iMac it says "ethernet cable not plugged in".
Check this out, a new Airport update was recently released and lists a fix for this:

"• Inability to create a computer-to-computer network, or share the Internet connection on some MacBook, MacBook Pro, and Mac mini computers"

If you're running 10.6 that could have been the problem ;)
Not sure what one has to do with the other??:confused:
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.