Direct X Problem after Parallels Installation!

Discussion in 'Windows, Linux & Others on the Mac' started by macfreak77, Aug 27, 2009.

  1. macfreak77 macrumors newbie

    Joined:
    Aug 27, 2009
    #1
    This is extremely urgent and any help would be apppreciated!

    I was running Bootcamp with Windows Vista smoothly until I decided to install Parallels 4.0 on my Mac 10.5.8. After installing Parallels, it loaded my Bootcamp installation which sort of freaked me out and so I closed Parallels without doing too much. When I booted Vista today, I tried running games that requried Direct X or enhanced graphics and they are not working! These games used to work fine before I had installed Parallels! I even tried fixing the Bootcamp installation by repairing the drivers through the installation cd that came with Leopard, but I still get the same problem!

    An example: I try running Project64, and it gives me a Direct X error 8876086A, stating that plugins are missing.
    Some games crash back to desktop without any error.

    Please help!
     
  2. Stridder44 macrumors 68040

    Stridder44

    Joined:
    Mar 24, 2003
    Location:
    California
    #2
    Have you tried installing the latest version of DirectX? (The package contains both DX 9 and DX 10)

    As ridiculous as it sounds, neither Vista and 7 come with the very latest version of DX 9. And it's not even offered in Windows Update, which is just irritating. I always install this update when reformatting.
     
  3. macfreak77 thread starter macrumors newbie

    Joined:
    Aug 27, 2009
    #3
    Hey, thanks.

    The problem is that I have Direct X 10 installed, at least that is what Dxdiag tells me. But what it also tells me is that in the display section, the direct x features are all listed as "NOT AVAILABLE" which I think means that there is a problem with the graphics, etc. All my games were running fine, it's just that after installing parallels, it's all messed up...
     
  4. ayeying macrumors 601

    ayeying

    Joined:
    Dec 5, 2007
    Location:
    Yay Area, CA
    #4
    You screwed up your windows right there.

    Go back into Parallels, let it do its magic, then reboot. Parallels 4 should be using 2 profiles, one directly for virtualization, then the other for boot camp. If you somehow randomly stopped the VM, it didn't change back to the other profile, therefore, windows thinks its still in a vm and causes all mayhem to run wild.
     

Share This Page