DirectX missing on Windows 7???

Discussion in 'Windows, Linux & Others on the Mac' started by Resso, Sep 14, 2009.

  1. Resso macrumors newbie

    Sep 14, 2009
    I have a MacBook Pro with two Nvidia cards but my bootcamp'd Windows 7 can't find directX and I can't install it (well, I can, but it can't be found). I'm running Leopard 10.5.8

    Any help would be appreciated, I bootcamp'd to play games and now I can't :mad:
  2. rgarjr macrumors 603


    Apr 2, 2009
    Southern California
    just google directx download and you will find it. Try downloading the offline version which is like 90MB.
  3. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    Are you getting this error from a particular game?
  4. Resso thread starter macrumors newbie

    Sep 14, 2009
    I've already downloaded and installed the DirectX from August 2009, but it still says the same "can't make DirectX file" or something like that error (right now, I'm on the leopard partition, I'll check the right text in a minute)

    The error comes from the Requiem:Bloodymare game, but I doubt it's the cause of the problem, because when I run the rating program, everything is around 5 or 6, but the video parts stay at 1... This is too ambigous, give me 5 minutes, I'll edit this post with the right info...


    The correct message is: "DirectX Graphics system Creation Failed"

    The Windows Experience Index is as follows:

    Processor: 6.4
    Memory (RAM): 5.9
    Graphics: 1.0
    Gaming graphics: 1.0
    Primary hard disk: 5.8



    I've seen I'm not the only one, and I'm just thinking it could be due to having two video cards in one laptop, and bootcamp somehow not knowing how to recognize the one I want to use. Does anyone know one of these?:

    a) how to disable one graphics card from Leopard
    b) how to enable the use of two video cards for bootcamp
    c) ... mind loop... If I remember I'll post it haha
  5. carlos700 macrumors regular


    Dec 17, 2004
    Omaha, NE
    Neither the 9400M or 9600M GT should give you a score of 1.0 for your WEI. That score makes me think Windows isn't seeing your graphics cards. Or that you need to update your WEI. I would make sure you have proper Windows 7 graphics drivers installed for your graphics cards.
  6. Stridder44 macrumors 68040


    Mar 24, 2003
    You're getting that error when installing the latest DirectX? Or when you're running a certain game, or does it happen with any game?
  7. Resso thread starter macrumors newbie

    Sep 14, 2009
    I just checked the device manager and in Display, the only thing appearing is a regular VGA adaptor (9400M and 9600M GT are missing). I installed the drivers from the BootCamp installer of my Leopard DVD...

    And to the other poster, the message appears when trying to launch Requiem, but as we're seeing, this isn't a problem with the game itself, but with windows not recognizing my video cards... I can't even turn Aero on haha
  8. Gav Mack macrumors 68020

    Gav Mack

    Jun 15, 2008
    Sagittarius A*
    Windows 7 installs a generic SVGA driver, then an Nvidia one from Windows Update. The boot camp installer tries to install it's version but after restart you're back to the generic SVGA driver.

    Go to Nvidia's website and download the Geoforce 9M drivers for Windows 7. Right click and run as administrator and on restart you'll have Aero and Directx.
  9. Resso thread starter macrumors newbie

    Sep 14, 2009
    I tried with the notebook Gforce 9M for Windows 7 64bit notebook drivers and I got this message:

    "The NVIDIA Setup program could not locate any drivers that are compatible with your current hardware. Setup will now exit"

    =/ Any more ideas?
  10. Resso thread starter macrumors newbie

    Sep 14, 2009

    EDIT: HELL YEAH! IT WORKED!! Thanks to this guy in another thread haha

Share This Page