Disable auto complete?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sagittaru, Jul 18, 2008.

  1. sagittaru macrumors member

    sagittaru

    Joined:
    Jul 10, 2008
    Location:
    Oklahoma
    #1
    How can I disable auto complete/correction for text message on iphone 3g?
    It's pretty annoying sometimes.
     
  2. vertigomhs macrumors member

    Joined:
    Jul 13, 2008
  3. ins0mniaque macrumors newbie

    Joined:
    Mar 13, 2008
    #3
    I'm not sure about the 3G and 2.0, but on my iPhone with 1.1.4, I can go to "Settings > General > International > Keyboards" and add a keyboard. I added the French Canadian one here. It allows me to switch keyboards while typing. The French Canadian keyboard doesn't trigger any auto-correction and has the same layout as the US one, only difference is that space is labeled "espace" and return is labeled "entrée".
     
  4. iPhone3G macrumors member

    Joined:
    Jul 9, 2008
    #4
    Unfortunately, the international keyboard swap does not work on the 3G and/or 2.0. Auto-correction still applies to the various international keyboards (including French-Canadian). It seems as though there is no fix for this texting issue as of yet (that I know of, at least).

    Anyone with ideas, please pitch in. I'm sure there are many who would love to disable this "feature."
     
  5. sagittaru thread starter macrumors member

    sagittaru

    Joined:
    Jul 10, 2008
    Location:
    Oklahoma
    #5
    I tried that on my iphone, french canadian still does trigger auto correction :(
     
  6. ins0mniaque macrumors newbie

    Joined:
    Mar 13, 2008
    #6
    Nice! At last auto-correction in french! ;)


    But for those still struggling with that issue, I found a fix on my friend's 3G. You just need to rename (or delete, but I don't recommend it) the text input file located at /System/Library/TextInput/TextInput_en.bundle (_en for english). Your phone needs to be jailbroken.

    Steps for unsavvy users:
    1. Start terminal (MobileTerminal)
    2. su <enter>, enter root password (default is alpine, but let's hope you changed it using "passwd <enter>".
    3. cd /System/Library/TextInput
    4. mv TextInput_en.bundle TextInput_en.bundle.backup
    5. Restart phone
    6. Enjoy not having to tap every word you type!
     
  7. sagittaru thread starter macrumors member

    sagittaru

    Joined:
    Jul 10, 2008
    Location:
    Oklahoma
    #7
    so its only possible to disable this autocomplete/correct on jailbroken huh? :(
     
  8. ins0mniaque macrumors newbie

    Joined:
    Mar 13, 2008
    #8
    AFAIK, yes. But why wouldn't you jailbreak your phone ?
     
  9. tsvb macrumors 6502

    Joined:
    Jan 28, 2006
    Location:
    Syracuse, NY
    #9
    It must have been coincidence but I jailbreaked my phone last night and then had no service so I restored.
     
  10. Raja.m macrumors newbie

    Joined:
    Dec 22, 2010
    #10
    Auto-correction off

    I m nt sure abt iphone 2g r 3g but its possible in iphone4.
    Go to Settings --> General --> Keyboard --> Auto-correction, switch to 'Off'
     
  11. Sean.n macrumors newbie

    Joined:
    Jan 6, 2011
    #11
    Thanks. It worked fine on my 3gs.
     

Share This Page