Disable Automatic Graphics Switching

Discussion in 'MacBook Pro' started by Ulfhedinn, Jun 29, 2013.

  1. Ulfhedinn macrumors newbie

    Joined:
    Jun 29, 2013
    #1
    OS = 10.8.4
    I have a MBP with an i5 and the dual GPU IntelHD/NVidia GeForce GT 330m

    I have downloaded the gfxCardStatus app in hopes of overcoming an issue I am having with a MBP. I would like to force the MBP to use the NVidia graphics only (both on battery and plugged in) and disable Automatic Graphics Switching.

    Whenever I attempt to set it as discrete only through the gfx app my system crashes. Also if I just go right to the enregy saver options and uncheck Automatic graphics switching the mbp crashes as well. Black screen and then auto restart. I can recreate this issue whenever I use an app that switches from the Intel HD graphics to the NVidia.

    In safeboot it starts up with discrete/NVidia and the Automatic graphics switching is disabled, the machine runs perfect this way but as soon as I boot into normal mode it reverts back. Is there anyway I can force discrete/Nvidia only preboot and keep those changes. I attempted to force discrete only in safe boot with gfxCardStatus, set gfxCardStatus to launch on startup, but as soon as I boot into normal mode it shows that the Intel graphics are running instead.

    Also I am aware that there is an actual hardware problem with the logic board but if I could get Automatic Graphics Switching disabled before Mac OS loads I can work around it.

    Also I have downloaded the most up to date Nvidia CUDA drivers and all Mac OS updates.

    I have also attempted pmset in terminal but this does not change anything

    "sudo pmset -a gpuswitch 0"

    I tried 0,1, and 2 not knowing which was which, still no go.

    Any help would be greatly appreciated.
     
  2. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #2
    Try removing the NVIDIA drivers and using the ones included in OS X.
     
  3. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #3
    How does Windows work.
    I am afraid other than disabling graphic switching there is nothing you can do. If that is so thoroughly broken, than that is just what it is.
     
  4. Ulfhedinn thread starter macrumors newbie

    Joined:
    Jun 29, 2013
    #4
    Safe boot disables graphic switching and the machine works fine then. What I need to know is how can I mimic this. Basically how can I get normal boot to boot like safe mode. Can I make a change in terminal via recovery that will disable that feature for normal boot?

    Can I remove all startup services/items/whatever to make it almost identical to safe boot?
     
  5. c1phr macrumors 6502

    Joined:
    Jan 8, 2011
    #5
    From your specs description, I'm assuming this is the 2010 (same model I have). In Lion, I had a terrifying bug with graphics switching that caused the entire screen to display just static whenever the Nvidia card was activated. Gfxcardstatus actually fixed the problem for me, and apparently Apple attempted to fix it in Mountain Lion.

    Lucky for us, Apple is fixing graphics related issues on the 2010 models for 3 years post-purchase date. I know taking your machine in for service sucks, but at least it should be done for free.

    http://support.apple.com/kb/TS4088
     
  6. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #6
    No. What safe boot does is not load anything but the most essential drivers. When booting Windows there is not graphics switching to begin with. If it only works in safe boot mode, chances are it only boots because the lack of drivers keeps many features from being activated.
    There is no muxing and not Intel GPU as that is all disabled at BIOS level.

    It seems to me there is some feature like the power savings feature of the 330M which keeps it from crashing. Does your notebook work if you force the Intel GPU for everything in (OSX obviously)??
    I think it might be the 330M which is broken and not so much the switching. Otherwise Windows should work well in normal mode.
     
  7. Ulfhedinn thread starter macrumors newbie

    Joined:
    Jun 29, 2013
    #7
    Yeah I think it is something with the NVidia, I tried to force just the Intel but as soon as I select Intel only in gfxCardStatus the same result happens. Screen goes black and it restarts. It seems odd cause it starts with Intel enabled so I would think it wouldnt need to make any type of switch but something is happening there.
     
  8. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #8
    In the energy saver control panel, accessible via the battery icon in your task bar, you can uncheck "Automatic graphics switching" which will force the nVidia at all times, without the use of any third party apps such as gfxCardStatus.
     
  9. c1phr macrumors 6502

    Joined:
    Jan 8, 2011
    #9
    Also, some apps ignore Intel only. Chrome is one of them (but I've found there are a few), and it won't work if you have an external monitor plugged in.
     
  10. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #10
    Chrome does not ignore Intel only. You just have to use gfxCardStatus. Apple doesn't offer a Intel only setting. Only auto switching or Nvidia only.
    Anyway the op seems very much informed about the switching settings.
     
  11. c1phr macrumors 6502

    Joined:
    Jan 8, 2011
    #11
    On the 2010 MBP, it still has a tendency to use the Nvidia GPU. It's a known issue with the 2010 and earlier models, and will never be fixed unless Apple decides to fix legacy hardware.

    Source: Post #6 - https://code.google.com/p/chromium/issues/detail?id=111720
     
  12. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #12
    I have a 2010 MBP and when Intel only is set Chrome cannot do anything about it, it will stay on the IGP.
    If you don't use gfxCardStatus there is simply no intel only feature. Automatic graphics switching always enables the dGPU on a 2010. No exceptions. There isn't even a sometimes.
    I don't think you understand that Intel only in gfxCardStatus and automatic graphics switching just isn't the same thing. Only an external display causes gfxCardStatus to actually disable Intel only and switch to auto or nvidia only.
     
  13. c1phr macrumors 6502

    Joined:
    Jan 8, 2011
    #13
    I'm well aware of what gfxCardStatus does. In some cases, it works fine, other cases it simply does not. This is due to issues with the 2010 models, there is no way around it, and it's a documented issue. Cody Kreiger (the author of gfxCardStatus) even calls his approach "nukeitfromorbitswitching" when a 2010 is detected, and has comments in his code for features he has to disable because they break on the buggy 2010 models.

    Even Apple doesn't allow their graphics switching flag to be used on 2010 models. [link]
     
  14. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #14
    Nothing in there says that the Intel only setting isn't working. Only that you cannot switch it on without relaunching some apps. gfxCardStatus used to just switch anyway and then you had to deal with horrendous "practically software rendering" performance until an application relaunch but it works. Now it just doesn't let you switch to Intel only unless all dependent apps are closed.
    It is the same still the otherway around. You can go from Intel only to nvidia while VLC is running but GPU acceleration is dead for that app until you relaunch. VLC is extremely choppy but at least relaunches quickly compared to apps like Chrome or iphoto.
    If you set Intel only, it does stay on and nothing in your links says otherwise. Intel only is never ignored by apps. But when it is not turned on at app launch one might as well just use nvidia only.

    I like the battery life of the 4702HQ on the Razer Blade 14". That is practically ultrabook level performance almost comparable to 13" ultrabooks. Some 15" with those BGA Quad Cores will be a nice notebook to switch too from our 2010 MBPs.
     

Share This Page