Disable automatic updates

Discussion in 'macOS' started by chrisblaze, May 29, 2010.

  1. chrisblaze macrumors member

    Joined:
    Mar 12, 2008
    #1
    Every time my system reboots, the software update wants to run. The things is, I have it uncheck in the preference pance so it shouldn't run at all. Anyone know what my problem might be?
     
  2. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #2
    Do you mean when the computer boots up or when you initiate a reboot?
     
  3. chrisblaze thread starter macrumors member

    Joined:
    Mar 12, 2008
    #3
    Once I log in after a restart or a power down, the software update runs, even when box is uncheck to do so.
     
  4. Duff-Man macrumors 68030

    Duff-Man

    Joined:
    Dec 26, 2002
    Location:
    Albuquerque, NM
    #4
    Duff-Man says...just to be clear and certain - are you sure it is Apple's software update that is running and not something for another application you may have starting up at login? Many apps do have auto-update checks in them nowadays.

    If if is Apple's and it for whatever reason is not remembering your settings to not check for updates, maybe try seeing if it is the pref file (/library/preferences/com.apple.softwareupdate.plist). Move the file somewhere in case you want to revert to it (it also contains any info about updates you've said to "ignore" for instance) then launch software update system prefs again and reset the settings you want....see if that resolves it.....oh yeah!
     
  5. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #5
    While inactivate updates are indeed kept in the Local SoftwareUpdate plist, scheduling data is kept in

    ~/Library/Preferences/com.apple.scheduler.plist

    alternatively it can be in

    ~/Library/Preferences/ByHost/com.apple.scheduler.plist.UUID

    Settings such as Automatic Download are typically found in

    ~/Library/Preferences/ByHost/com.apple.SoftwareUpdate.plist.UUID

    I would isolate the scheduler plist since it isn't following what you set.

    In addition, since it is launching at login, I would check your

    ~/Library/LaunchAgents and /Library/LaunchAgents in the event that peruser launchd is calling a launch agent which is calling for a Software Update check.
     
  6. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #6
    I believe that you are correct. Software Update has only four options for the regularity of its checks--daily, weekly, monthly, and never. What is more, Software Update checks are silent unless it finds new software. It does not check more than one per day and it does not bug the user unnecessarily.

    It is likely that the OP has one or more applications that check for updates when launched.
     
  7. chrisblaze thread starter macrumors member

    Joined:
    Mar 12, 2008
    #7
    So I removed the com.apple.scheduler and the com.apple.SoftwareUpdate.plist file restarted the system and the software update will pops up. Yes, it is the Apple Software update because it displayed that I had to install the new version of Java.
     
  8. eatpeople macrumors newbie

    Joined:
    Aug 18, 2010
    Location:
    Pirate-ship near Seattle, WA
    #8
    Same issue / reproducible

    Experiencing same as chrisblaze - Software Update is spawning constantly since updating my MBP 2.4GHZ to 10.6.4; it sometimes runs approx. 1x/hour, sometimes not for a few hours and occasionally as soon as I say "not now", it immediately crops-up two or three minutes later. It always shows at least 2x/day; often many more times.

    MisterMe, helpful info however this is not correct:
    > It does not check more than one per day and it does not bug the user unnecessarily.

    This is not caused by a 3rd-party app or extension and is directly due to Software Update. I won't qualify my Mac mojo/know-how here but suffice to say this is the OS and not a 3rd-party causing Update to continually run. I'll be disabling it via Terminal but a shame it won't recognize the preference-choice in Sys. Prefs. - my experience is nearly verbatim that of original poster.
     

Share This Page