Disable Clamshell mode forever?

Discussion in 'MacBook Pro' started by dusk007, May 25, 2011.

  1. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #1
    I want to keep my MBP from ever entering clamshell mode.
    All I can find about it in google are explanations how to enter and leave clamshell mode. But I never ever use it only accidentally activate it when I close my MBP to enter sleep and put something on the table and the mouse wakes it or remove some USB device after closing it and it enters clamshell.

    It is annoying I want to disable the feature entirely. There has to be some kind of switch.
     
  2. ShootingStars macrumors member

    Joined:
    May 13, 2011
    #2
    Theres an app called insomniaX that keeps your macbook from going to sleep EVEN when you close it

    The caffeine app does NOT do this
     
  3. JTToft macrumors 68040

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #3
    - I think you misunderstood him/her. He/she wants to keep the computer from waking, not keep it from sleeping.
     
  4. xxBURT0Nxx macrumors 68020

    xxBURT0Nxx

    Joined:
    Jul 9, 2009
    #4
    then how would one go about waking the computer once it's asleep?
     
  5. JTToft macrumors 68040

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #5
    - By opening the lid, I presume.
    He/she wanted to keep it from waking because of USB input (a mouse, for instance).
     
  6. dusk007 thread starter macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #6
    I am a He.
    I close the lid so the freakin thing goes to sleep and I want it to stay asleep.
    Yet at home I almost always keep it connected to an external screen and use a mouse too. At night when I finish up and want to go to sleep I close the lid for the MBP to sleep too. Often I have closed the lid and than found I need my iphone and once I disconnect it wakes up. Or all I do is move the mouse just a little by putting something on the table and then the damn thing wakes up and shows stuff at the external screen.

    The solution is to let it sleep again and wake up, or launch display prefs and pres detect screen. Both are really annoying and since I never ever actually want to use my external screen only (either primary or both never only the secondary) I just want to disable the whole feature. Once asleep nothing but opening the lid needs to wake it.

    Shootingstars and Burton didn't seem to understand my first post. I don't know why but now with more words any confusions shouldn't be no more.
     
  7. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #7
    Uncheck "allow bluetooth devices to wake computer", I believe there is a setting for USB as well, somewhere.
     
  8. xxBURT0Nxx macrumors 68020

    xxBURT0Nxx

    Joined:
    Jul 9, 2009
    #8
    afaik there are no ways to set "preferences" for what will and will not wake your mac from sleep mode...
     
  9. mac00l macrumors 6502

    Joined:
    May 3, 2011
    #9
    Just set your computer to go to sleep after 10 mins of inactivity, and when you are using it, just use caffeine to prevent it to go to sleep. That way when it is closed, it will go to sleep in a few minutes.
     
  10. dukebound85 macrumors P6

    dukebound85

    Joined:
    Jul 17, 2005
    Location:
    5045 feet above sea level
    #10
    why not charge your phone with a wall charger and avoid that scenario all together? ie only plug it into your computer if you want to synch and charge without the computer for all other times
     
  11. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #11
  12. dusk007 thread starter macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #12
    @duke I don't have a wall charger. Bought it in the states 2 years ago and never really saw a reason to shed out some money for the European plug.

    @snaky where is this check box? It doesn't really matter though it is a USB mouse. I have it mostly for gaming and bluetooth mice are just to expensive and cannot really compete with this one.

    @GGJstudios total fail. Pleas read more than the first two sentences of my posts or forget about it. I do know very well WHY my MBP wakes.

    The only working solution might be the one from Mac00I but that seems like an awful work around. And it might create as many problems as it solves. It happens quite often that I want it to stay awake for a longer time when downloading stuff or doing something else unattended (I just turn down the brightness and the display sleeps after a while). Even when sitting in front of it I sometimes just put some slides up and not touch it for 10 mins. Yet when I go to bed I like it that everything including the ext. hdd spins down and well everything goes quite.
    I was hoping there was some switch that would just undo every wake command as long as it stays closed. Seems there isn't or it is buried so deep nobody knows about it. I guess I will just have to live with it the way it is.
     
  13. Soom macrumors newbie

    Joined:
    Nov 30, 2009
    #13
    I have exactly the same problem

    Same **** here - I always use 2 displays for my work, but I never need to use clamshell mode. I hate when the MBP wakes up by accident in the middle of sleep and turns on the clamshell mode - after this I have to manually return all the windows into their original positions - this is complete nonsense!
    I could not find a way to turn off completely the clamshell mode either...
    I think this is a drawback Apple have to fix...
     
  14. ladytonya macrumors 6502a

    Joined:
    Oct 14, 2008
    #14
    Even if I knew the answer to your question, your attitude here is a "total fail" and I wouldn't answer it. People are just trying to help and you've done nothing but make an a$$ out of yourself to those that have attempted to help you. Why would anybody else want to even bother trying? :eek:
     
  15. pake macrumors regular

    Joined:
    Sep 19, 2006
    Location:
    Delft
    #15
    The solution is to click sleep before closing the lid or disconnected the monitor beforehand also.

    I have the same problem and haven't been able to find a real solution. And you're right, there should be a switch for the user; there is, however, a system boolean that the monitor activates, so the system knows if it should enter clamshell mode or not. If you find someone with enough programming skills to change that boolean irreversibly, then let me know.
     
  16. dusk007 thread starter macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #16
    That is what I am doing too. I hit "sl" Enter to tell Alfred to send the notebook to sleep. That way at least when it wakes it doesn't enter that useless clamshell mode.

    I can do programming but where do I need to look to find that boolean value?
     
  17. mattonthemoon macrumors regular

    mattonthemoon

    Joined:
    Feb 25, 2007
    Location:
    Toronto, ON
    #17
    I may be crazy but I swear my 2011 MBP charged the iDevices even while asleep.
     
  18. pake macrumors regular

    Joined:
    Sep 19, 2006
    Location:
    Delft
    #18
    It's in system.kext. There's a IORegistry Boolean called "AppleClamshellCausesSleep" which is set to "False" if a second display is plugged in or "True" when not.
    But, I have no idea how to change it permanently or impede the display from changing it.

    And regarding the charging: my 2009 MBP will keep charging USB devices when it enters sleep only if it's plugged in to power, but will stop charging them if it's running on battery.
     

Share This Page