Disable DMG Verification in El Capitan GM

Discussion in 'OS X El Capitan (10.11)' started by jer2eydevil88, Sep 13, 2015.

  1. jer2eydevil88 macrumors regular

    jer2eydevil88

    Joined:
    Feb 6, 2004
    Location:
    USA
    #1
    Apple took it upon themselves to break the Disk Utility in every conceivable manner. Including the preferences section that has allowed me to disable verifying the checksum of every DMG file I open. It's a pet peeve of mine to have to wait for that to complete before it opens a DMG file for an installer.

    Can anyone tell me an alternative way to disable it? My Google Fu is weak on this one.
     
  2. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
  3. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #3
    At least to me, it is really starting to look like Apple's only offer to the public is going to be a glued together case with all soldered components and few if any software configuration options.
    Amazing how attitudes change once you become "King of the Hill"

    Sorry for the thread hi-jack.
     
  4. matreya macrumors 65816

    matreya

    Joined:
    Nov 14, 2009
    #4
    Have you tried this?

    sudo defaults write com.apple.frameworks.diskimages skip-verify true
     
  5. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #5
    Seems to work, but you don’t need to use sudo for this.
     
  6. jer2eydevil88 thread starter macrumors regular

    jer2eydevil88

    Joined:
    Feb 6, 2004
    Location:
    USA
    #6
    This worked for me! Thank you!
     
  7. fisherking macrumors 601

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #7
    what i miss...i had a hack a few years ago that, when i sent a dmg to the trash, ejected the disk image automatically. anyone know how to do that? always seemed like an unnecessary extra step...
     
  8. allan.nyholm, Sep 14, 2015
    Last edited: Sep 14, 2015

    allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Aalborg, Denmark
    #8
    I think the script is in here: http://hints.macworld.com/article.php?story=20120728123233584
     
  9. mads10000 macrumors newbie

    Joined:
    Feb 6, 2015
    #9
    I just tried this : sudo defaults write com.apple.frameworks.diskimages skip-verify true

    But get a new error: no mountable file systems? Is there any trick to fix the second error?

    Cheers
     
  10. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #10
    This error only occurred after you changed the setting? This normally suggests that something is wrong with the DMG file.

    By the way, the correct command is:
    Code:
    defaults write com.apple.frameworks.diskimages skip-verify -bool true
     
  11. jer2eydevil88 thread starter macrumors regular

    jer2eydevil88

    Joined:
    Feb 6, 2004
    Location:
    USA
    #11
    As of OS X 10.11.3 this fix no longer seems to work. The disk verification is no longer disabled and re-applying it doesn't have the same effect.
     
  12. malexander16 macrumors newbie

    malexander16

    Joined:
    Jul 19, 2016
    #12
    I ran into this problem with Sibelius, but I found out another workaround.

    If you Navigate to System/Library/CoreServices and then launch the Installer app, it will then ask you to find and open a .pkg. Navigate to where you have your disk image saved, and select it. It'll bypass the verify and go straight to installing.
     
  13. Zmav macrumors newbie

    Zmav

    Joined:
    Feb 19, 2017
    #13
    Will that stop verifying all apps ( that aren't from the store or verified) or just the one that I have selected ?
     

Share This Page