Disable dock in Mavericks? Or, at least get autohide-delay to work again?

crackers8199

macrumors newbie
Original poster
Jan 6, 2014
5
0
is there a way to disable the dock in mavericks, even if temporarily? it keeps bouncing up when i've got stuff running in full screen and i get down near the bottom of the screen, and i end up clicking on something i don't want and it takes me out of my full-screen app to whatever it is i clicked on. it's incredibly annoying at best, almost a dealbreaker at worst...

i know in previous versions you could change the auto-hide delay to be some huge number, and that would usually fix it...but those settings seem to have no effect in mavericks...is there any way to do it? even if i could do something like turn the dock off with command-option-D while i'm in full screen, that would be fine...but it doesn't work. even if i've hidden the dock, when i'm in a full screen app the dock keeps jumping back up at me...
 

jbarley

macrumors 68040
Jul 1, 2006
3,867
1,712
Vancouver Island
Launch Terminal from the Utilities folder, which is inside the Applications folder. Once launched, type or paste the following command in:

defaults write com.apple.dock autohide-delay -float 1

Then type
killall Dock
to restart the Dock process to see the changes.

That gives you a full one second of delay. If you want a longer delay, make the number bigger, like 1.5 or 2. If you want a shorter delay, you can type in 0.1 or 0.5.
 
Last edited:

crackers8199

macrumors newbie
Original poster
Jan 6, 2014
5
0
Launch Terminal from the Utilities folder, which is inside the Applications folder. Once launched, type or paste the following command in:

defaults write com.apple.Dock autohide-delay -float 1

Then type
killall Dock
to restart the Dock process to see the changes.

That gives you a full one second of delay. If you want a longer delay, make the number bigger, like 1.5 or 2. If you want a shorter delay, you can type in 0.1 or 0.5.
the problem is that this doesn't work in mavericks, which is the point of my post. it used to work, before i upgraded...but the upgrade seems to have broken it, which is the problem.

if someone has this working on mavericks and can point out to me how to get it working on my particular machine, i'd love to hear it...
 

jbarley

macrumors 68040
Jul 1, 2006
3,867
1,712
Vancouver Island
It works for me on 10.9.1, just make sure to use a lowercase 'd' in the command 'com.apple.dock'

Edit: it appears this delay hack only works for standard windows on the desktop.
Once an app is full-screen the delay reverts back to zero for some reason.
Sorry for any confusion...
 
Last edited:

fisherking

macrumors 604
Jul 16, 2010
7,114
2,057
ny somewhere
i never use the dock, have had it locked away since about 10.5. i use 'dock gone'...which is no longer supported, but continues to work (i installed it on this mac in 2011).

it's a little buggy, but it keeps the dock locked away. i use launchpad to open things, and the app switcher to move about. i can work fullscreen (safari, logic, etc) but WITH the menubar visible/active. and no dock popping up.

ideal on a 13" macbook pro! i have it set to hide or appear with a key command (in my case, "command-option-control-D").

if you want to try it (am ASSUMING it will install in 10.9...), or have any questions...PM me...
 

crackers8199

macrumors newbie
Original poster
Jan 6, 2014
5
0
It works for me on 10.9.1, just make sure to use a lowercase 'd' in the command 'com.apple.dock'

Edit: it appears this delay hack only works for standard windows on the desktop.
Once an app is full-screen the delay reverts back to zero for some reason.
Sorry for any confusion...
i wonder if this is a bug in the OS...

----------

i never use the dock, have had it locked away since about 10.5. i use 'dock gone'...which is no longer supported, but continues to work (i installed it on this mac in 2011).

it's a little buggy, but it keeps the dock locked away. i use launchpad to open things, and the app switcher to move about. i can work fullscreen (safari, logic, etc) but WITH the menubar visible/active. and no dock popping up.

ideal on a 13" macbook pro! i have it set to hide or appear with a key command (in my case, "command-option-control-D").

if you want to try it (am ASSUMING it will install in 10.9...), or have any questions...PM me...
i'd be open to trying that, but i'd prefer to find an official way to do it if possible...i'm wondering if they didn't intend to disable autohide-delay in 10.9 and just introduced a bug somehow that broke it.
 

crackers8199

macrumors newbie
Original poster
Jan 6, 2014
5
0
Have you tried the Secrets.prefpane to change the animation speed? I just did and it seems to work (as you desired it to) in full screen.
it works, but not very well...mainly because the dock is still there and the labels still cover what i'm trying to look at at the bottom of the screen. also, that incredibly long slow animation speed also applies if i try to hide the dock for any other reason at any other time (if i want to hide it briefly to get a bit more real estate, for instance)...
 

mekeirc

macrumors newbie
Feb 13, 2014
1
0
has anyone ever figured out a way to make this happen?
I can confirm that the following method is working on Mavericks 10.9.1 (13B42)

Code:
defaults write com.apple.dock autohide-delay -float 0
Set the float to something high, I typed 100 but you're free to input a larger number. This hid the dock entirely for me. Note that the "d" in dock has to be lower case, and you may need to manually kill the process via activity monitor.
 

cstout

macrumors newbie
Sep 2, 2011
13
11
10.9.2

Just my two cents, but I use this command to customize a netboot image I use and using the same command as I used in 10.8 worked (with the capital D in Dock). Even though I previously used killall Dock to check the results, in Mavericks this modification seems to require a reboot. After reboot the dock autohide modification works fine.

The command I used previously is:
Code:
defaults write com.apple.Dock autohide-delay -float 1000 && killall Dock
 
Last edited:

dmccloud

macrumors 65816
Sep 7, 2009
1,027
35
Anchorage, AK
defaults write com.apple.dock autohide-delay -float 1 worked fine for me in Mavericks. I also tried a few different values to verify that the command was in fact changing the delay time for the dock to appear.
 

vr2nr

macrumors newbie
Jan 19, 2012
3
0
Solves My Multi-Monitor Dock issues

I used this, putting the float at 100 or so. The dock is basically gone.

So now I've reached kind of a Dock Nirvana...

  • No Dock false repositioning in multiwindow
  • No Dock using up space on my screen
  • Full functioning Dock on Control D
  • No delay when I want to reveal Dock (e.g., you have to hold your mouse at the bottom of the screen and wait a fraction of time to reveal).
  • Hide Dock again with Control D

Now I just wish I could merge icons together on the Dock into folders like iOS. I know there's Launchpad, but on the Mac, just haven't got into it yet I guess. Happy to hear suggestions.

I can confirm that the following method is working on Mavericks 10.9.1 (13B42)

Code:
defaults write com.apple.dock autohide-delay -float 0
Set the float to something high, I typed 100 but you're free to input a larger number. This hid the dock entirely for me. Note that the "d" in dock has to be lower case, and you may need to manually kill the process via activity monitor.
 

Ddyracer

macrumors 68000
Nov 24, 2009
1,786
31
Code:
defaults write com.apple.dock autohide-delay -float 10000
then:
Code:
killall Dock
This seems to work in 10.9.3. with revert to:
Code:
defaults delete com.apple.dock autohide-delay
Code:
killall Dock
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.