General Disable EarPods in-line controls

Discussion in 'Jailbreaks and iOS Hacks' started by chrf097, Mar 11, 2014.

  1. chrf097 macrumors 68040

    chrf097

    Joined:
    Dec 16, 2011
    #1
    So my EarPods are starting to mess-up. I have no issue with sound or a anything, but my remote is going absolutely HAYWIRE. Without even touching the remote, songs will play, pause, fast foward/rewind, skip, or even Siri will activate or my phone will hang up during a phone call! The volume buttons are fine and the center button also works just fine but it keeps activiating itself!

    Until I can get a new pair, I just want to disable in-line remotes completely. Surely there's a tweak or .plist edit i have to do to fix this major annoyance?
     
  2. Ryan Burgess macrumors 6502

    Joined:
    Jan 26, 2013
    #2
    I believe you can do this by installing "Activator". Then set it up under wired headset, so that when the button is pushed say "suppress original action". I believe this will accomplish what you want.

    This however, will only work for the center button not the volume buttons afaik.
     
  3. chrf097 thread starter macrumors 68040

    chrf097

    Joined:
    Dec 16, 2011
    #3
    It works somewhat. Pressing and holding the button is now disabled (no more random siri!), but it still registers button pushes.
     

Share This Page