rexone

macrumors regular
Original poster
This is just one of those things that many of us hate - developers add a new 'feature' that is inexplicable in its purpose but is annoying and cannot be turned off... Firefox has a new URL bar with a stupid, enormous red highlighted box around it apparently just in-case you are too stupid to know where to enter your search text...
Previously this could be disabled via > about:config and then turning to false a number of > browser.url.update settings but V77 has broken that.
Anyone know how to turn it off or is their 'we know best' arrogance going to win & I'll have to retire FF as my browser of choice.
I should add... it's not that the function particularly disrupts my use beyond making me cranky everytime I use it. I just have a big problem with developers adding pointless functions that cannot be optioned off.
 

Partron22

macrumors 68030
Apr 13, 2011
2,655
799
Yes
I'm using FF 77.0.1 and don't see any red highlighted box, just the usual 1 pixel black outline.
 
  • Like
Reactions: rexone
Comment

rexone

macrumors regular
Original poster
I'm using FF 77.0.1 and don't see any red highlighted box, just the usual 1 pixel black outline.
I'm using the same version... It pops-out & looks like this...

Screen Shot 2020-06-04 at 1.39.37 pm.jpg
 
Comment

AppleSmack

macrumors 6502
Jun 30, 2010
303
102
Are you using a theme, or is that the default theme? Do you have some accessibility features enabled in OS or in Firefox?
 
  • Like
Reactions: rexone
Comment

rexone

macrumors regular
Original poster
Okay. I'm certainly not alone with this annoying issue.
This reddit fix I found got rid of the expanding URL bar & disabled the suggestions list but my in browser the initial bar is still outlined in red (not black);
  1. Open about:config and Accept the Risk and Continue.
  2. Paste browser.urlbar.disableExtendForTests and create a new Boolean and leave it True.
  3. Paste browser.urlbar.maxRichResults and set the value to 0.
  4. Restart browser.
 
Comment

splitsko

macrumors newbie
Jun 16, 2020
1
0
Okay. I'm certainly not alone with this annoying issue.
This reddit fix I found got rid of the expanding URL bar & disabled the suggestions list but my in browser the initial bar is still outlined in red (not black);
  1. Open about:config and Accept the Risk and Continue.
  2. Paste browser.urlbar.disableExtendForTests and create a new Boolean and leave it True.
  3. Paste browser.urlbar.maxRichResults and set the value to 0.
  4. Restart browser.

Registered here just to say thank you. It worked.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.