Disable horizontal scrolling w/ Magic Mouse?

Discussion in 'OS X Yosemite (10.10)' started by BrianDye, Jan 24, 2015.

  1. BrianDye macrumors newbie

    Joined:
    Jan 15, 2015
    #1
    For starters, this terminal command line DOES NOT WORK for me:
    defaults write com.apple.driver.AppleBluetoothMultitouch.mouse MouseHorizontalScroll -bool NO
    (Along with powering the mouse down, and back on)


    This hasn't ever bothered me, but I recently got into that Minecraft game with some friends from work, and literally just the angle of my finger will make the magic mouse horizontally scroll to a different "item" in my inventory or whatever so I keep using the wrong stuff.

    Literally without sliding/lifting my finger, just "twisting" it makes the horizontal scroll go nuts. I have tried that terminal command, powering the mouse off until it disconnects and reconnects, even tried restarting the Mac and it still scrolls.

    I loved this mouse before, but now I despise it. Don't feel like going out across town and buying a USB mouse to fix this.

    (Mid-2011 27" iMac running Yosemite)
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    Seems that the device that you use (the magic mouse) is not well-suited to the use that you are now choosing to use it.
    If, as you say, you now despise your mouse, then use a different one that does not have the distraction of the multitouch top surface.
    IMHO, that would be better than trying to warp the magic mouse to a use that you may still find challenging.

    Have you tried Steermouse? That (or some other input device manager, like Better Touch Tool) may give you some alternative settings on your magic mouse that can be helpful... without having to manually undo settings changes when you go back to a more "normal" mouse use.
     
  3. Vudo2 macrumors newbie

    Vudo2

    Joined:
    Feb 7, 2017
    Location:
    Ohio
    #3
    Have you solved this issue?? I recently installed El Capitan on Mac Pro (early 2009) and I CAN NOT disable horizontal scrolling on my system NO WAY - NO HOW!!! Tried the command lines, shutting down mouse and back on, rebooting everything in all sorts of combinations and NOTHING works! I absolutely can not use the system with this feature enabled as that I can not work in Libre Office with the horizontal scrolling activating every 5 seconds and disabling any possible usability of the app!

    Seriously need help on this!
     

Share This Page