Disable hyperthreading?

Discussion in 'Mac OS X Lion (10.7)' started by mmanary, Sep 22, 2011.

  1. mmanary macrumors newbie

    Joined:
    Sep 22, 2011
    #1
    I just got a 12-core Mac Pro running OS X 10.7 (my first Mac! of course my work bought it) and hyperthreading is automatically enabled. I want to disable it to check performance changes on a program. I have looked everywhere for the additional preference panes but cannot find any of the old ones that used to exist in Developers/Extras. Any advice?

    For those interested: The program is the Burrow-Wheelers Aligner, and it is NEVER able to access the virtual cores. All outputs from both iStat and Activity Monitor indicating I am only using 50% (i.e. 600%) of total CPU, and all the virtuals are unused, so I want to disable and see if it will access 100% (i.e. 1200%) of CPU.
     
  2. ljonesj macrumors 6502a

    ljonesj

    Joined:
    Oct 20, 2009
    Location:
    Kingsport TN
    #2
    i dont think you can disable the hyperthreading as its built into the processors themselves and enabled by default
     
  3. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #3
    You can disable it if you install Xcode and the CHUD tools. Here is my CPU palate. Notice the checkbox. It is used to verify and check compiles etc.
    [​IMG]
     
  4. mmanary thread starter macrumors newbie

    Joined:
    Sep 22, 2011
    #4
    I have installed the Developer Tools, and followed a lot of advice online, but can't seem to find the CHUD. Was it an option that I chose not to install? How do I get it?

    Thanks so much for responding by the way!
     
  5. derbothaus, Sep 23, 2011
    Last edited: Sep 23, 2011

    derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #5
    You need to get an Apple developer account. I believe the CHUD tools can be downloaded with the free version of the account. Some stuff is for paid subscription.
    Here is the link you can go to after logging in:
    http://connect.apple.com/cgi-bin/WebObjects/MemberSite.woa/wa/download?path=/Developer_Tools

    Go to developer tools on side column and search CHUD.

    edit: you may not need CHUD after all. go to:
    /Library/Application Support/HWPrefs/CPUPalette.app
    Launch if it is there. I install so many things I forgot where this came from.
    You can also disable any of the cores you like.
     
  6. mmanary, Sep 23, 2011
    Last edited: Sep 23, 2011

    mmanary thread starter macrumors newbie

    Joined:
    Sep 22, 2011
    #6
    Curiously, the install does not work. I can download CHUD 4.6.2 disk image, but the install fails while 'verifying'. I went past that, because the files were copied already, and generated the Processor preference pane. It only loads in 32-bit System Preferences, but has the hyperthreading checkbox. As soon as system preferences is turned off, however, it defaults to turning hyperthreading back on. Advice? I am still using 100% apple stuff, but honestly paying $7000 for a computer that can only use half its CPU is a little frustrating.
     
  7. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #7
    Use the CPUpalatte.app.
    Is it in the location specified above?

    Also, download Cinebench and look at the processor for multi benchmark. It'll use them all. You need to use multi thread aware applications to take full advantage. That's why most users opt for the 6-core or Quad cores, they are cheaper and, for the most part, all you'll need unless you have highly specialized software.
    It's not the HW its the software.
     
  8. mmanary thread starter macrumors newbie

    Joined:
    Sep 22, 2011
    #8
    Yeah I have tried that too - again, it opens no problem, but then when I uncheck hyperthreading, and turn it off, then open it again, it is turned on (and has never disabled hyperthreading). Do I need to save settings somehow? I think the problem is it doesn't detect the processors in the first place? Because all the images are blank gray squares? and if I call CPUPallete from the terminal it has all sort of error messages.

    Thanks for all your help. I know it is the software, but I cannot change the aligner we use, so I need to make my computer utilized as best as possible.

    ----------

    Error messages from the terminal are:

    bjc[222]: Class VMUSymbolOwner is implemented in both /System/Library/PrivateFrameworks/CHUD.framework/Versions/A/Frameworks/CHUDSymbolication.framework/Versions/A/CHUDSymbolication and /System/Library/PrivateFrameworks/Symbolication.framework/Versions/A/Symbolication. One of the two will be used. Which one is undefined.

    ^^ This one repeats for everything in the VMU class, i.e. VMUSymTabLoadCommand, VMUTask, etc

    then

    *** WARNING: +[GRDataSet defaultColors]:151 - +[GRDataSet defaultColors] is deprecated. It now comes with a substantial performance penalty - convert to using -[GRChartView defaultPlotColors]. ***
    WARNING: Could not determine processor information.
    WARNING: Could not determine memory controller information.
    WARNING: Could not determine Operating System information.
     
  9. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #9
    You should not need to save settings. The Intel Icons I have are my own hacked version so no worries there. Yours will look different.
    I don't know man, maybe uninstall CHUD and use CPUpalette. Here is a screen of it successfully turning off hyper threading in Cinebench. Notice palette AND iStat on the menubar. Seems to be working fine. I'm stumped.
    [​IMG]
    [​IMG]
     
  10. edenorchestra macrumors member

    edenorchestra

    Joined:
    Oct 4, 2011
    Location:
    Pennsylvania
  11. dawsonj macrumors newbie

    Joined:
    Feb 6, 2011
    #11
    Hyperthreading disabled in lion server by default

    For what is is worth I came across this post trying to figure out what my quad core i7 Mac mini server came with lion only shows four rows or columns rather than eight in activity monitor.

    Using sudo nvram -d SMT and rebooting I now show 8 columns however every second one only has green blocks init thus far.

    Anyways it appears lion server disables hyper threading by default unless someone can clarify my findings differently
     
  12. Ulf1103 macrumors 6502

    Joined:
    Jan 5, 2011
    #12
    where are those files copied too?
    I'm trying to install the CHUD myself (on Mountain Lion),
    but it keeps failing...

    How did you fixed that?
     
  13. DanCornett macrumors newbie

    Joined:
    Jun 25, 2011
    #13
    Dynamic hyperthreading toggle - in Xcode

    See this posting for an app in Xcode tools to enable / disable hyperthreading (and number of CPUs active). The setting does NOT persist across sleep or reboot: http://www.logicprohelp.com/forum/viewtopic.php?f=5&t=88835

    (You run the Instruments app, cancel the initial screen, and then change the CPU Preferences).
     

Share This Page