Disable mouse in Terminal.app?

Discussion in 'OS X Yosemite (10.10)' started by LinMac, Nov 20, 2014.

  1. LinMac macrumors 65816

    Joined:
    Oct 28, 2007
    #1
    I would like to _COMPLETELY_ disable the mouse in Terminal.app so it returns to old behavior. I have seen it moving the cursor around in the Terminal on later systems and I want to disable this completely.

    Please skip the questions why would you want to, suggestions of 3rd party replacements, or anything except what I asked. Thank you for your respect in this matter.
     
  2. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #2
    Sounds like a way to get people to want to help you...
     
  3. joedec macrumors 6502

    joedec

    Joined:
    Jul 25, 2014
    Location:
    Cupertino
    #3
    I don't understand the question. I use the mouse to copy/paste in Terminal, that's about it. What else is there?
     
  4. mfram macrumors 65816

    Joined:
    Jan 23, 2010
    Location:
    San Diego, CA USA
    #4
    You can scroll in some apps. For example, use 'less' to read a file and you can use the scroll feature on the mouse to scroll through the file. Some apps can even accept clicks on the window.

    My initial idea is to change the TERM variable to something like 'vt100'. But I haven't tried if that works to disable mouse control.
     
  5. joedec macrumors 6502

    joedec

    Joined:
    Jul 25, 2014
    Location:
    Cupertino
    #5
    Right, I am aware of the option-click cursor placement, and scrolling. I forget about these things because I never use them.

    I am just not sure what the OP wants, I mean move the mouse off the window and its no longer used in any way. In fact the default behavior is as soon as you use the keyboard the mouse pointer disappears.
     
  6. shewey, Sep 1, 2015
    Last edited: Sep 1, 2015

    shewey macrumors newbie

    Joined:
    Sep 1, 2015
    #6
    I'd like to be able to do disable the mouse scroll in terminal.app too.

    This is the problem: While editing in vim, touching the mouse scroll wheel moves the cursor up/down. This gets frustrating when you are copying & pasting within a file as it's very easy to inadvertently scroll while moving the mouse pointer.

    Scenario: You position the cursor ready to paste, use the mouse pointer to highlight what you want to copy - inadvertently scroll - and now the cursor has moved to a different line so you can't paste. The control you have over the scroll isn't very fine so moving back to where you want to paste is a pain.

    When I find out how to disable this I'll post back here.

    EDIT: setting TERM=vt100 works. It may turn off too many advanced features though.

    Function to disable scrolling when calling vim:
    myvim() { OLDTERM=$TERM; TERM=vt100; vim "$*"; TERM=$OLDTERM; }
     
  7. vexorg macrumors 6502a

    Joined:
    Aug 4, 2009
  8. shewey macrumors newbie

    Joined:
    Sep 1, 2015
    #8
    That's a nice idea. I'll stop mqking typos too :)
     
  9. mfram macrumors 65816

    Joined:
    Jan 23, 2010
    Location:
    San Diego, CA USA
    #9
    You could try messing with Settings -> Profiles -> Advanced -> "Declare terminal as:" to vt100. That would turn off the mouse stuff. But you'd probably also lose color support.
     
  10. vexorg macrumors 6502a

    Joined:
    Aug 4, 2009
    #10
    Preferences -> Profiles -> keyboard -> "Scroll alternative screen" : untick it to disable mouse scroll controlling the cursor
     

Share This Page