Disable "none of your preferred networks are available" window?

Discussion in 'macOS' started by Elo Everidge, Feb 8, 2008.

  1. Elo Everidge macrumors newbie

    Joined:
    Jan 23, 2008
    Location:
    Berlin, Germany
    #1
    Right after logging in Leopard displays the window "None of your preferred networks are available" when Airport is activated and you are not connected to any wireless network even though Leopard detects one or more. I find this rather annoying, considering the fact that I use my laptop at many locations where I actually use wired network access (and yes, Leopard even shows the window if you have a perfectly fine cable connection to the Internet).

    Anybody know if and how one can disable this "feature"? I'd be perfectly happy to click the Airport icon in the menu bar myself in the rare occasions that I want to connect to a network that I have never used before.
     
  2. Chris Grande macrumors regular

    Chris Grande

    Joined:
    Jun 17, 2003
    #2
    Uncheck "Ask to Join New Networks" in System Preferences -> Network -> AirPort.
     

    Attached Files:

  3. Elo Everidge thread starter macrumors newbie

    Joined:
    Jan 23, 2008
    Location:
    Berlin, Germany
    #3
    Never mind, I found the answer here:
    http://discussions.apple.com/thread.jspa?threadID=1257227

    System Preferences>Network>Airport>Uncheck "Ask to join new networks"

    As the original poster in that thread, I always assumed that meant that OS X would automatically join unknown networks without asking. But that's not the case.

    (Edit: Thanks for the quick reply, Chris Grande.)
     
  4. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #4
    That would be a pretty big security risk.
     
  5. Chris Grande macrumors regular

    Chris Grande

    Joined:
    Jun 17, 2003
    #5
    And one that was in Windows for a rather long time, wasn't fixed until XP SP2 if I remember correctly. I don't think any version of Mac OS (all the way back to OS 9) would join a network without asking first.
     
  6. spamdumpster macrumors 6502a

    Joined:
    Jan 22, 2008
    #6
    Good thread, I needed to disable that on my new MBA.

    Also, shouldn't it be, "None of your preferred networks IS available"? I was always taught that "none" was singular."
     
  7. gustavopi macrumors member

    Joined:
    Oct 29, 2008
    Location:
    Brazil
    #7
    And what about Ethernet (Internet by cable modem)? In theory I'm in a network of my Internet provider and my Mac connect without asking, is there a risk in this case?
     
  8. andreasfmpro macrumors newbie

    Joined:
    Oct 31, 2003
    Location:
    Athens, Greece
    #8
    Uncheck "Ask to join new networks"?

    I unchecked the box "Ask to join new networks".

    Now, I do not get the dialog box prompting me to select a network. Great!

    Of course, this way I cannot connect to the internet via Wi-Fi, so I have to invoke the drop down menu myself, in order to select my network.

    Yeah, that was very helpful.
     

Share This Page