Disable OS X fullscreen in chrome (youtube)

Discussion in 'macOS' started by .psd, Oct 24, 2013.

  1. .psd, Oct 24, 2013
    Last edited: Oct 24, 2013

    .psd macrumors member

    Jun 15, 2012
    This is on a new machine, freshly wiped and updated. It used to be a problem on other MacBooks I've owned, but it hasn't been a problem lately until now.

    If you fullscreen a video in youtube in chrome, some videos use OS X's fullscreen mode instead of just going fullscreen like every other video on the entire internet, and most videos on youtube. The details of why this is a huge problem are beyond the scope of this thread.

    How do I prevent Chrome from initiating OS X's fullscreen mode? Even Safari doesn't use OS X's fullscreen mode for youtube videos.
  2. bwat47 macrumors regular

    Oct 1, 2013
    Chrome uses its own bundled/custom version of flash by default (pepper flash). Maybe try going to chrome:plugins and disabling the built-in "PPAPI" flash and see if that helps? (When you go to chrome:plugins you should see two flash plugins after clicking "details" on the top right. One "PPAPI" version, this is the built-in pepperflash, one "NPAPI" version, this is the "system" flash.).

    Also, just because I can't resist, why is this a huge problem? :D
  3. DerekMin, Nov 4, 2013
    Last edited: Nov 4, 2013
  4. Lailoken macrumors member

    Nov 21, 2006
    Browse to:


    And enable it. Not 100% sure if this is present in the version of Chrome you are using, but it is for me.
  5. m4v3r1ck macrumors 68020


    Nov 2, 2011
    The Netherlands
    Because I'm unable to revert to windowed mode for 'normal' viewing after a full screen video.

    1. Keys for presentation mode and full screen are greyed out.


    2. The exit full screen button (blue) does not work in Chrome as in e.g. Safari?


    Anyone a solution for this?

    ~ Cheers

Share This Page