Disable Resume (I mean REALLY disable it) (not a solution, i ask a question)

Discussion in 'Mac OS X Lion (10.7)' started by /V\acpower, Jun 9, 2012.

  1. /V\acpower macrumors 6502a

    Jul 31, 2007
    Ok, here is my problem.

    I love most of OS X Lion new "interface features", but as many peoples, I really don't like "resume", in fact, I really don't understand why someone ever considered it a "desirable feature", especially "by default". Really, when I close an app, that partly because I want to "clean" and start fresh again, when I reboot the computer, same thing. Having everything auto-resume is really, really just making desktop management more complicated and repetitive. Resume is perfect in iOS because everything is fullscreen, so you need it to keep state. On a desktop OS like OS X, really if I want to keep the tabs open i'll just minimize the window...


    ok, now that my rant is done.

    I have a "technical" question for you all.

    I know that you can turn off "app-quitting resume" in the System Preference in the General Tab.

    I know that since one of the update, you can keep the "reopen app on startup" box uncheck.

    Both are disabled.

    However, when I shutdown OS X, and an App, lets say Safari is open with dozens of tab, when i'll open safari again on a fresh startup, it will reopen every tab.

    It doesn't does that on regulat "cmd+q", really just after the app have been automatically shut down by OS X, while it is ... shutting down.

    So my question : HOW DO I STOP THIS BEHAVIOR ??!!!! (I'm just really pissed everytime it happen to me and it just did.)

    Thank you all for your future help.
  2. mofunk macrumors 68020


    Aug 26, 2009
    yeah I want to know too. I just updated my Mac to Lion and I hate it. Resume is the worse for me. I work on my computer a lot. Every app that I open, it will "Resume" where I left off. WTH I'm not reading a book. I'm working. So basically its like two steps back. I have to close all the windows I worked on the previous day before I can start on anything new. Frustrating. Viewing fotos or working on the web... ugh!
  3. sidewinder macrumors 68020


    Dec 10, 2008
    Northern California


    Uncheck the "Reopen windows when logging back in" option when your reboot. If you are running Mac OS 10.7.4 it will remember the setting....




    You need to learn how to use Google or some other search engine.

    Preferences --> General --> then uncheck "Restore windows when quitting and re-opening apps"

  4. dcorban macrumors 6502a


    Oct 29, 2007
    This does not affect the behaviour we are discussing. Safari in particular seems to ignore this setting if it is closed as part of a reboot or software update. I have had app restore and shutdown restore disabled since day one and Safari still restores tabs on occasion.

Share This Page