Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Vanarak19

macrumors 65816
Original poster
Feb 18, 2008
1,062
33
Latest Beta seems to have a feature where if you single click on the desktop, it hides all apps and shows the complete desktop.

How do I turn this off?
 
  • Like
Reactions: Alvin777

chabig

macrumors G4
Sep 6, 2002
11,317
9,009
That's Stage Manager. Turn off Stage Manager to get the "regular" behavior back.
 

MacGizmo

macrumors 68040
Apr 27, 2003
3,107
2,425
Arizona
That feature has a specific toggle you can turn on/off in the Desktop & Dock System Settings – it has nothing to do with Stage Manager (though you can obviously use it in conjunction with State Manager).
 

bogdanw

macrumors 603
Mar 10, 2009
5,746
2,768
At the bottom, the Shortcuts button
Shortcuts.jpg
 
  • Like
Reactions: Alvin777

chabig

macrumors G4
Sep 6, 2002
11,317
9,009
I don't have those settings in Ventura. Maybe they only appear when a mouse is connected. Do you use a mouse, MacGizmo?

Screenshot 2023-09-03 at 8.09.52 AM.png
 

bogdanw

macrumors 603
Mar 10, 2009
5,746
2,768
You're in the Keyboard & Mouse settings, I believe. The on/off toggle is in the Desktop & Dock System Settings in the macOS Sonoma Beta.
I presumed everyone can see the obvious one, so I pointed out the setting you don’t seem to see.



From Terminal:
read setting “Click wallpaper to show desktop items”

Code:
defaults read com.apple.WindowManager EnableStandardClickToShowDesktop

write
Click wallpaper to show desktop items – Always = 1
Code:
defaults write com.apple.WindowManager EnableStandardClickToShowDesktop 1

Click wallpaper to show desktop items – Only in Stage Manager = 0
Code:
defaults write com.apple.WindowManager EnableStandardClickToShowDesktop 0

I don't have those settings in Ventura.
Not available in Ventura, only in Sonoma.
 

macmus12

macrumors regular
Jul 14, 2022
175
43
Can I disable this annoying behavior with Stage Manager ?
I like SM but this one click to show desktop is annoying.
 

Alvin777

Suspended
Aug 31, 2003
503
39
Hi, I think it's a macOS Sonoma bug or design flaw, I already have Stage Manager disabled and have set the 'Click wallpaper to reveal desktop' set to 'Only in Stage Manager' (even disabling both 'Show Items' but it still does it whenever I click on the wallpaper which mean Finder windows would disappear which means one can't drag and drop a file in an open Finder Window (Finder apps like System Settings would disappear too when the wallpaper's clicked).

The only solution is to click on Finder on the dock and Option-Command-H. We hope it's fixed in the next update.
 
Last edited by a moderator:

chabig

macrumors G4
Sep 6, 2002
11,317
9,009
I already have Stage Manager disabled and have set the 'Click wallpaper to reveal desktop' set to 'Only in Stage Manager' (even disabling both 'Show Items' but it still does it whenever I click on the wallpaper...
That's not how it's supposed to work. Mine doesn't do that. Try changing the setting and setting it back to maybe fix the behavior.
...which mean Finder windows would disappear which means one can't drag and drop a file in an open Finder Window
I don't understand this comment. I can drag and drop just fine. As long as you don't click on the desktop, Windows stay where they are. You can click on icons.
 
  • Like
Reactions: Alvin777
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.