Disable SIP : command not found

Discussion in 'OS X El Capitan (10.11)' started by chip1, Mar 14, 2016.

  1. chip1 macrumors member

    Joined:
    Jan 14, 2014
    #1
    dear all,

    My mac mini late 2012 has been upgraded to Mac OS X El Capitan. Yet recently when I tried to configure the resolution via switchresx, the system said that the system integrity protection of El Capitan prevents such act. So I started up the mac mini pressing command r and enter the recovery mode. And enter "csrutil disable" in terminal. But was responded by a message "command not found". Any advice?
     

    Attached Files:

  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    Your recovery partition is out of date. How did you install El Capitan?
     
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    Your recovery system (the utilities window that you posted) appears to be Mountain Lion.
    Look at the icon for Reinstall OS X. It shows the icon used for Mountain Lion.
    El Capitan would show a multi-colored X
    Plus the window widgets (red, green, yellow buttons in the top left corner) are wrong for El Capitan.
    And, the csrutil command does not exist in a Mountain Lion system.

    So, if you have upgraded to El Capitan, and that install somehow missed the Recovery partition. You will need to fix that if you want to disable SIP.
    The Recovery Partition should update itself if you simply reinstall OS X.

    Download the El Capitan installer app from the App Store.
    best choice is to Quit the installer after it completes the download, then create a bootable flash drive for the install. Search for "create bootable installer for El Capitan", or download DiskMakerX, and use that app to create your bootable installer.
    Boot to that installer after you have made one. Reinstall El Cap. That should fix your Recovery System partition.
    There's other methods for this, but that is what I would do.

    If all this does not get you a current Recovery system - Do you have File Vault turned on?
    Turn File Vault OFF, then try the El Capitan install again.
     

Share This Page