Disable smart sleep - sleepimage reappears

Discussion in 'macOS High Sierra (10.13)' started by MacUse-R, Mar 26, 2018.

  1. MacUse-R macrumors member

    Joined:
    Dec 24, 2017
    #1
    I have disabled smartsleep (hibernation 0 ) on my MacBook Pro 2011 with High Sierra.

    But when i delete the sleepimage and restart the macBook Pro the sleepimage reappears.

    Also i think that the smartsleep is still active, when i check hibernation status in Terminal it says "hibernation 0", i.e. the smartsleep hibernation should be disabled.


    Anybody has an idea what is going on? Have i forgot some steps?
     
  2. chabig, Mar 26, 2018
    Last edited: Mar 26, 2018

    chabig macrumors 603

    Joined:
    Sep 6, 2002
    #2
  3. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    Four-step sequence to disable hibernation mode and get sleep image under control:
    (Note: this works with sleepimage files in Low Sierra and "lower". You'll have to try it to see if it works in High Sierra)

    First, disable hibernation mode :
    sudo pmset -a hibernatemode 0

    Next, delete the existing sleep image file:
    sudo rm /private/var/vm/sleepimage

    Now, create an empty file and name it 'sleepimage' :
    sudo touch /private/var/vm/sleepimage

    Finally, change its flag to immuable :
    sudo chflags uchg /private/var/vm/sleepimage

    Now, OS X won't be able to rebuilt over your sleepimage file since it is locked.
     
  4. hallux macrumors 68030

    hallux

    Joined:
    Apr 25, 2012
    #4
    It will not, I tried it on mine already. I found success with just setting the pmset variables to 0 as suggested by @chabig
     
  5. MacUse-R, Mar 26, 2018
    Last edited: Mar 26, 2018

    MacUse-R thread starter macrumors member

    Joined:
    Dec 24, 2017
    #5
    I did these four steps and restarted the MacBook Pro and the sleepimage is still 0 Bytes, so as long as it doesn't write a sleep image to my SSD I'm happy. So thanks.
    My goal is actually not to have the smart sleep mode disabled but to stop major writes made by the smart sleep mode to the SSD.

    I haven't still read the link posted by chabig, but that seems to involve some other steps?
    --- Post Merged, Mar 26, 2018 ---
    sleep settings.jpeg

    This is the info I get from pmset -g
    Does it look as I have the correct things disabled? There are some things I don't even understand what they are, for example "sms", womp, ttyskeepawake, acwake?
    --- Post Merged, Mar 26, 2018 ---
    EDIT: If I only want to stop the sleep image writes to my SSD do I still need to set the autopoweroff and standby to 0 ?
     

Share This Page