Disable Startup Chime in Sierra

Discussion in 'macOS Sierra (10.12)' started by davvanc, Oct 1, 2016.

  1. davvanc macrumors member

    Joined:
    Oct 29, 2015
    #1
    Running the old
    code
    sudo nvram SystemAudioVolume=%80
    command in Sierra's terminal from the recovery partition, I get an error "command sudo not available" or the like, cannot remember exactly.
    Anyway the once silent chime is back on my 2009 MacPro 4,1 flashed to 5,1.
    Tried Onyx, which has that option in the Parameters section, no luck
    Ideas?
     
  2. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    you can mute the audio before rebooting. or plug a cable (or just a miniplug) into the headphone jack so you don't hear it.

    that terminal command (i don't know it), but %80? maybe look into this, perhaps %0 would mute it (again, am not sure).
     
  3. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #3
    That won't work, I have a cable plugged into mine to a wireless transmitter to my hearing aids. Even if I haven't turned that on yet, the startup chime still comes through the iMac's speakers.
     
  4. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #4
    how often do you boot up anyway? i assume you sleep your mac at night?

    you could also try changing the sound effects settings in system prefs; for example, NOT play sound effects thru the internal speakers (not sure that would do it, just a thought).
     
  5. fischersd macrumors 601

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #5
    Can you use sudo commands at all? (might be because SIP is enabled). I just did this on my Sierra system to test, the command was accepted fine.

    To disable SIP, boot up in recovery mode, go to terminal and type

    csrutil disable

    (you can re-enable it after changing the parameter for SystemAudioVolume).

    And, that command to mute the startup chime is taken right from the community forums guys:
    https://discussions.apple.com/thread/4001727?tstart=0
     
  6. foxlet macrumors 6502

    foxlet

    Joined:
    Aug 5, 2016
    #6
    You don't need to add sudo when in the recovery environment. Terminal starts in a root shell by default.
     
  7. davvanc, Oct 2, 2016
    Last edited: Oct 2, 2016

    davvanc thread starter macrumors member

    Joined:
    Oct 29, 2015
    #7
    I had SIP disabled before I updated the El Cap system, assumed that was the same. However, the update reinstated the SIP. So I disabled it, and reset the Sound parameters as someone suggested. Those were also reset during the update, I certainly didn't do it intentionally. So, after disabling SIP, resetting the Sound preference pane, and hitting the F10 key before rebooting, I finally got a quiet reboot. Hope that sticks! The 2009 MP4,1 flashed to 5,1 has always been a little strange in the way the nvram works, hard to explain as it varies from case to case.
    Anyway, issue resolved(?) Thanks for your help everyone!
     
  8. hwojtek macrumors 65816

    hwojtek

    Joined:
    Jan 26, 2008
    Location:
    A small rural village in western Poland
    #9
    Or just unplug everything from the computer (in case of a Mac Pro it means both front and rear audio jacks), select "Internal Speakers" in Sound preference pane, move the volume slider all the way down, restart.
     

Share This Page