Disable startup sound Lion iMac 2011

Discussion in 'macOS' started by jackoatmon, Oct 2, 2011.

  1. jackoatmon, Oct 2, 2011
    Last edited: Oct 2, 2011

    jackoatmon macrumors 6502a


    Sep 15, 2011
    Hi there. The internet is full of fixes to disable the insanely loud startup sound on my iMac that prevents me from turning on my computer at night for fear of waking the GF.

    These fixes do not seem to work, because they all seem to involve volume level adjusts, yet the startup chime is obviously not governed by the volume level on my computer, as it chimes loud no matter what I have the volume set to, and it chimes through the awful integrated speakers regardless of what i have plugged in the 1/8" jack.


    Has anyone managed to destroy this ugly sound in Lion? Typical new-to-osx guy comment, but is there some way we can just navigate to the sound file and delete it or replace it with a silent sound?


    (ps the computer is one of the new imacs 27" 3.4, in case model matters. FYI - things that do not work - Psst, StartupSound.prefpane)
  2. App Downloader macrumors member

    Feb 12, 2011
    all i did was to mute the volume before shut down, and it worked...
  3. jackoatmon thread starter macrumors 6502a


    Sep 15, 2011
    It's model specific. On new iMacs with Lion the sound appears to be part of whatever Apple calls the BIOS, rather than on the operating system itself. Or so I'm coming to believe.
  4. interrobang macrumors 6502

    May 25, 2011
    The real question is, why are you turning your Mac on? Do you have a lot of power failures where you live?
  5. jackoatmon thread starter macrumors 6502a


    Sep 15, 2011
    I use Windows 7/OSX about 50/50 depending on what's best for the task I'm doing. Also, full restarts are the best way to ensure you've fully reset all of your overclocking settings once you've finished whatever you were overclocking for. I restart it at least 2-3 times per day.
  6. neilmacd macrumors 6502

    Apr 18, 2010
    I have a 2011 iMac with Lion and muting before a restart stops the sound. Lowering or increasing volume also affects it :confused:
  7. Steve's Barber macrumors 6502a

    Jul 5, 2011
    This pisses me off to no end.

    I can't believe after all these years Apple still covets the annoying start up chime with no easy way to suppress it. Sure, I use sleep a lot but occasionally I do power down. It's very disruptive when booting your macbook in a staff meeting (or a library) and you forget to mute it.

    There were utilities in SL to disable it but this must've pissed off one of the Lion coders who had nothing better to do (like work on bugs).
  8. hwojtek macrumors 65816


    Jan 26, 2008
    Poznan, Poland
    The startup sound has nothing to do with the OS X.
  9. Steve's Barber macrumors 6502a

    Jul 5, 2011
    I know. It's firmware related.

    But why wait until Lion to thwart any attempts at disabling it?
  10. RestUnknown macrumors regular

    Aug 25, 2011
    A bump yes, but I didn't want to start a new thread regarding this well known issue. Even though I have a Macbook Pro 3,1 and not an iMac.

    I must find a way to disable it, turning down the volume doesn't work as it should be. It works fine the first time (not always though), but if I restart again and don't touch the volume, the boing is extremely loud.
    From time to time I'm on Bootcamp and if I switch back to Mac, this method doesn't work at all.

    Suggestions like "why don't you simply put your Macbook in standby mode, it barely consumes power", aren't helpful. At night it simply has to be turned off, I want a clean start the next day.

    Script and prefpane didn't work. But I'm convinced someone has a working solution, it has to be.

  11. James Craner macrumors 68000

    James Craner

    Sep 13, 2002
    Bristol, UK
    I know it is not the most elegant solution, but if you don't want to hear the startup sound then plug a headphone jack into the headphone socket. It's what I do.
  12. RestUnknown macrumors regular

    Aug 25, 2011
    This doesn't work, my headphones are constantly plugged in.
  13. James Craner, Feb 19, 2012
    Last edited: Feb 19, 2012

    James Craner macrumors 68000

    James Craner

    Sep 13, 2002
    Bristol, UK
    Works for me, the startup 'Bong' goes through the headphone output. In sound preference panel, I have play sound effects through 'selected sound output device'. Just to clarify I have a Mac Pro, not an iMac and I use external speakers, so perhaps this is why it works on my system.
  14. RestUnknown macrumors regular

    Aug 25, 2011
    Yeah guess so, my preferences are the same as yours but always goes through the internal speakers.

    Damn you Apple.
  15. Schtumple macrumors 601


    Jun 13, 2007
  16. RestUnknown macrumors regular

    Aug 25, 2011
    If you would have read the thread, you could see the prefpane doesn't work for my Macbook.
  17. jaknudsen macrumors member


    Jan 25, 2005
    Oslo, Norway
    On my 2011 iMac 27, startup is silent if headphones are disconnected and the sound is muted in prefs. But not otherwise*– would love a solution that doesn't require me to unplug and mute.
  18. PaulKemp macrumors 6502

    Jun 2, 2009
  19. Drew017 macrumors 65816


    May 29, 2011
    East coast, USA
  20. dringerb macrumors newbie

    Jun 24, 2012
    Hold down mute

    Not a great solution, because you have to remember, but: hold down the mute key as the machine is booting.
  21. umbilical macrumors 6502a

    May 3, 2008
    FL, USA
    yes it work, really but!!! I dont remember the perfect match on preferences for do it...
  22. bndoarn, Aug 7, 2012
    Last edited: Aug 9, 2012

    bndoarn macrumors 6502a

    Mar 16, 2008
    I know this is an old thread but if anyone is still looking for a solution, here is a work around with an applescipt.

    Create a new apple script with the following:

    on quit
    set volume output volume 0
    continue quit
    end quit
    Then compile it. Then when you go to save it, for File Format choose Application. Next, make sure the "Stay open after run handler" option is checked. Save the application where ever you like.

    Now go to System Preferences > Users & Groups > Login Items. Click the plus button to add an application. Choose the one you just made and check the box to hide it.

    This step is optional but if you want to, you can use a program like Dockless which you can use to hide the dock icon of the app while it's running. This will also hide it from the app switcher.

    Now every time you shutdown your computer, the volume will be set to 0 and the start up chime will not happen.

    EDIT: I just realized that as of now, there is a bug in ML where if you hide the app's dock icon, the script will no longer work.
  23. chickenlegs, Aug 20, 2012
    Last edited: Aug 20, 2012

    chickenlegs macrumors member


    Dec 9, 2007
    Bristol, UK
    Can't seem to alter startup chime

    It doesn't seem to matter what I do, I cannot turn the volume down of my iMac's startup chime. I've tried pretty much everything mentioned in these forum posts; psst, ninja, sound.prefpane, hitting the mute on shut down, hitting the lower volume on shut down....nothing seems to lower or turn off the startup chime. For some unknown reason, the startup chime has got REALLY loud. I don't mind the chime, I just need to quieten it down a little!
    Is this a Lion issue as none of the software solutions appear to help?
    Any ideas welcome.

    24" iMac mid-2007 OSX 10.7.4
  24. fm.illuminatus macrumors newbie

    Aug 1, 2011
    I absolutely despise that sound for a number of reasons. I wonder if you could boot pull up the EFI pre-boot environment and nuke the sound file...


Share This Page