Disable WebRTC in Safari 12.1.2 and on iOS 12.1

MacUse-R

macrumors regular
Original poster
Dec 24, 2017
180
19
Like the title says, how do i disable WebRTC in Safari 12.1.2 on Mac OS X 10.13.6, and also how do i disable it on ios 12.1?

I have only found information and guides online which gives old info which doesn´t work anymore, for example the thing to "Disable Legacy WebRTC API" in the developer menu in Safari is not working since that option is not even there anymore.

Also the other suggestion to go to Experimental functions in the developer menu and "Remove Legacy WebRTC API" is not there either.

So it seems these are all old solutions for earlier Safari versions and not for Safari version 12.1.2?

Surely there must be some way to disable it, even if its a bit complicated?

My public IP address is leaking and i´m not happy at all about that. How can Apple not make it easy to disable WebRTC, do Apple think that people want their IP addresses to get leaked.
Thats a shame that i must resort to using other Web browsers at the moment where WebRTC can easily be disabled.

So if anybody knows how i can disable WebRTC in Safari on Mac OS X and on iOS, especially on Mac OS X i would gladly hear about it.

EDIT: I also wonder if Javascript can be enabled per website on Safari 12.1.2, meaning that javascript is always disabled but then one can enable it for the one particular website that you are visiting?
 
Last edited:

KALLT

macrumors 603
Sep 23, 2008
5,134
3,181
Your device will necessarily expose an IP address. If you want to conceal your IP address, then you must use a VPN service or proxy while browsing.

Legacy WebRTC had a design flaw in Firefox and Chrome that exposed the IP address even while using a VPN service. This is where the confusion comes from. These bugs have since been fixed. Whether WebKit was susceptible at all, I do not know (as WebKit introduced WebRTC much later), but Apple removed the legacy WebRTC APIs in favour of a new API. If you want additional protection, then make sure that you disable access to your microphone and webcam by default or always in Safari preferences.
 

MacUse-R

macrumors regular
Original poster
Dec 24, 2017
180
19
You should learn more about IP addresses https://en.wikipedia.org/wiki/IP_address
So instead of saying "you should learn more about IP addresses" why dont you tell me. That IP address is visible in the Leak test, when i do the same test from for example Firefox with WebRTC disabled there is no IP address visible, not the public and not the local. Of course i know that an IP address is visible normally, but in this case its visible in the WebRTC leak test.
 

MacUse-R

macrumors regular
Original poster
Dec 24, 2017
180
19
Your device will necessarily expose an IP address. If you want to conceal your IP address, then you must use a VPN service or proxy while browsing.

Legacy WebRTC had a design flaw in Firefox and Chrome that exposed the IP address even while using a VPN service. This is where the confusion comes from. These bugs have since been fixed. Whether WebKit was susceptible at all, I do not know (as WebKit introduced WebRTC much later), but Apple removed the legacy WebRTC APIs in favour of a new API. If you want additional protection, then make sure that you disable access to your microphone and webcam by default or always in Safari preferences.
Okay thanks. So that my IP is visible in the WebRTC leak test when using Safari is not considered a leak then, i thought that could expose my IP to malicious parties so to speak, of course i know that an IP is visible for the website i visit etc.
But im still curious why other people doesnt see their IP in that test when using Safari 12.1.2?
So do you consider it normal that the leak test also showed my local IP with Firefox a short while ago when i did the test, just curious?

Okay so you mean that for a person who uses a VPN then Safari will only expose the VPN IP address in the WebRTC leak test and not the real IP address?
[doublepost=1567616677][/doublepost]
Doesn't on my Mac, FWIW.

View attachment 856050
Strange, mine is visible, then that tells me even more that my IP should not be visible in that particular test.
Have you by any chance disabled java on your Mac, or disabled the microphone and camera? Since not even your Media device ID:s are visible. If Java is disabled then it will not show an IP there.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.