Disabled Java - Mountain Lion not sluggish now

Discussion in 'OS X Mountain Lion (10.8)' started by jacg, Jul 31, 2012.

  1. jacg macrumors 6502a

    jacg

    Joined:
    Jan 16, 2003
    Location:
    UK
    #1
    I was getting a lot of spinning beach balls in Aperture and generally clunky transitions when moving between spaces. Switching between apps was unusually slow, even for a HDD MBP (8GB RAM). I kept an eye on Activity Monitor but no sign of major culprits, apart from 17 GB Pageins v 8 GB pageouts in 24 hours.

    Anyway, I noticed a flash of a spinning blue beach ball so I went to Safari Prefs and disabled Java. No restart required, everything just seems smoother now.

    Maybe there was just some back ground process that has by coincidence stopped now, but I present my experience here in the hope that it may help someone else sometime.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Disabling Java in Safari is highly recommended for safe computing, as well. You should enable it only when on a trusted site that requires it.
     
  3. ghsNick macrumors 68020

    ghsNick

    Joined:
    May 25, 2010
    #3
    Which one do you recommend be disabled? Javascript or Java?

    Does this look right?
     

    Attached Files:

  4. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    Java is NOT Javascript, the only thing they have in common is the name, your settings are OK, leave Javascript enabled.
     
  5. walkie macrumors 6502

    Joined:
    Feb 13, 2010
    #5
    If you disable JavaScript most web pages won't work!, disable only Java.
     
  6. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #6
    In itself, there is is nothing about Java that should cause your machine to slow down.
    It is possible that you had some app or process that did require Java, which went went mad and started eating up CPU and memory resources. Though conceivably a process that did not use Java could do that.

    Merely killing the rogue process should be good enough.

    Java has got some bad press recently -- deservedly so -- but there's is nothing wrong with having a Java installation on your Mac.
    Disabling it in the browser is all you need to do.
     
  7. jacg thread starter macrumors 6502a

    jacg

    Joined:
    Jan 16, 2003
    Location:
    UK
    #7
    Scrolling quickly through RAW files in Aperture still eventually slows down my MBP, now with 16 GB RAM (go a bit slower and it seems to be fine). But nothing like the slow down I was getting when I had Java enabled. I guess a more scientific test would be to turn it back on...

    I noticed that Adobe Photoshop Elements 10 has a blue spinning stall cursor, of a different design though. It behaves like the whole app is written in Java and looks like it is running on Windows 95. I guess that's why I avoid it at all costs.
     
  8. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #8
    What is your hard drive capacity and how much of it is free?
     
  9. jacg thread starter macrumors 6502a

    jacg

    Joined:
    Jan 16, 2003
    Location:
    UK
    #9
    750 GB capacity, 55 GB free.

    Try quite hard not to let it drop below 50 GB.
     
  10. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #10
    This is your problem. You are way under the 10% free capacity threshold. Archive at least 25 GB of your files to raise your hard drive free capacity to at least 75 GB.
     
  11. jacg thread starter macrumors 6502a

    jacg

    Joined:
    Jan 16, 2003
    Location:
    UK
    #11
    Thanks for the advice. I will get archiving!
     

Share This Page