Disabled permissions - re-enable?

Discussion in 'macOS' started by dburney, Sep 15, 2006.

  1. dburney macrumors member


    May 24, 2006
    We installed Tiger on a G4 733 today. We ran the combo update for 10.4.6 (instead of .7 - I'm a little leary of that release). We downloaded Onyx, ran the optimization for prebinding purposes, repaired permissions.

    Apparently the machine wasn't restarted after all of this - the artist when to lunch, came back and tried to wake up the computer, all there was was a blue screen. Upon restart we had a kernel panic. I ran fsck via single user mode, I zapped the PRAM, attempted to boot with start up items disabled, but the kernel panic kept coming back. I booted from the Tiger install disk and found that I could only repair the drive - not verify or repair permissions - which I thought was strange. Then I tried to archive and install - it wouldn't show the drive so I could pick it as the disk to install to.

    I finally got the drive to show up via Target Disk Mode on my G5. Drive Genius will show the volume and device, but won't mount the device. I can run every test repair there is except repair permissions. When I attempt to repair permissions it tells me permissions are disabled on the drive. I'm not sure how this happened, but I do know that permission problems can cause a kernel panic. So I'm assuming that's what's going on here - however, the typical solution is to repair permissions, but my permissions appear to be turned off altogether. Is there any way from single user mode or any other method to "re-enable" disk permissions? I'm not very optimistic at this point, I'm imaging the drive to a disk image on my G5 in hopes that we may recover some of todays data. Fortunately the original machine we moved the artist from just last night is still intact (it's going to be a server). I just want to be sure there's no easier way out this than wiping the drive and starting over.
  2. tdhurst macrumors 601


    Dec 27, 2003
    Phoenix, AZ

    You seem to have what I would call "dead hard drive."

    You can try to repair permissions all you want (by the way, there's no such thing as turning permissions off), but it sounds like your drive died.
  3. dburney thread starter macrumors member


    May 24, 2006
    That's what I thought - but I figured a dead drive wouldn't show both device and volume in Drive Genius. And the drive isn't that old (maybe a year) - I wouldn't have expected it to up and die so suddenly (prior to this install it was a senior artists machine and it's SMART status was fine the last time I checked the permissions, etc.). Oh well.

Share This Page