Disabling Firefox back/forward from horizontal scrolling...

spaceballl

macrumors 68030
Original poster
Nov 2, 2003
2,856
240
San Francisco, CA
Hi there,

So I have recently enabled two finger scrolling on my iBook G4. In theory, it works perfectly. I love it in Safari. The only problem is that I hate Safari. So in Firefox, unless i slowly perfectly move my fingers left and right, there is of course some left/right movage.. which causes the browser to navigate to the previous/next page. I understand this feature for random mice w/ horizontal scroll wheels, but I would like to disable this in firefox to make two finger scrolling more useful. Ideas?

-Kevin
 

ephramz

macrumors member
Jan 14, 2004
55
0
It's quite easy to set Firefox to have the same horizontal scrolling behavior as Safari
Just go type
about:config
in the address bar. This will bring up a large list of all the user preference settings. There's a site on mozilla here: http://preferential.mozdev.org/preferences.html
that explains most but not all of them. You can filter to just the ones you need by typing "horizscroll" in the filter box. The one you need to adjust is mousewheel.horizscroll.withnokey.action
which should be set to 0 (click on the number to modify its setting). The options are:
* 0 : Scroll document by X lines
* 1 : Scroll document by one page
* 2 : Move back/forward in history
* 3 : Make text larger/smaller

so it's probably set to 2 by default on yours, like mine. Hope that helps. Made firefox much more pleasant for me!
 

spaceballl

macrumors 68030
Original poster
Nov 2, 2003
2,856
240
San Francisco, CA
I don't know why... but for some reason, I thought nobody would have the answer to my question... thanks so much, ephramz!!!
-Kevin
 

davecotter

macrumors newbie
Sep 13, 2007
14
1
update

the new names are:

browser.gesture.swipe.left
browser.gesture.swipe.right

set them to an empty string (delete what is there)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.