Disabling internal speaker in Mac Pro

Discussion in 'Mac Pro' started by cAPS lOCK, Nov 4, 2009.

  1. cAPS lOCK macrumors member

    Joined:
    Nov 3, 2009
    #1
    The way my Mac Pro always worked is that if I wanted to hear sound I just plugged my headphones in the front. When it was unplugged, no sound came out. This is how I need it because I'm using this at work.

    All of a sudden, when my headphones are unplugged I can hear the sound coming out of the box. I didn't even know it had an internal speaker.

    When I got to Sys Pref > Sound > Output, it says Headphones - Built-in Output when they are plugged in. When I unplug it it switches to Internal Speakers - Built-in Output.

    I can mute the internal speakers one but when I used to change the volume with the headphones unplugged it stayed muted rather then unmute.

    I don't know if I explained myself clearly but I just wanted it to go back to how I had it so I don't accidentally play something in the office.
     
  2. crazyrog17 macrumors regular

    Joined:
    Jan 13, 2009
    Location:
    Michigan
    #2
    I had the same problem at work. I had a pair of broken headphones, so I chopped off the 3.5mm plug and inserted it into the back audio jack. When I wanted to listen to something, plugged in the headphones and tadaa.

    That seems to be the most simple solution as software can always reset, but hardware will not change unless physically modified.
     
  3. cAPS lOCK thread starter macrumors member

    Joined:
    Nov 3, 2009
    #3
    Hmmm interesting... Just plug something into the jack on the back? I may just have to try that. Thanks.
     
  4. admo macrumors member

    Joined:
    Aug 24, 2009
    #4
    My MacPro (the 2006 model) did a similar thing. I have speakers plugged into the speaker jack in the back. Audio came out of the external speakers and the internal speaker. I have a small headphone splitter (kind of thing you get at Radioshack so two headphones can share one jack) that I put in teh headphone jack that is on the front of the MacPro. That disabled the internal speaker. Every once in a while I would take that out to see if a software update fixed the problem, as well as mess with the audio preferences.

    Then one day I took the jack out, and the internal speaker works as I would expect it to, it is silent, with my external speakers working. Not sure what did it. This was all under various updates of Tiger. I have Snow Leopard now, and it is still good.

    The internal speaker chimes on startup, and that is it.
     
  5. lannister80 macrumors 6502

    lannister80

    Joined:
    Apr 7, 2009
    Location:
    Chicagoland
    #5
    I wish there was a way to silence the internal speaker ON STARTUP.

    My MDD G4 would chime the startup tone through the headphone jack if anything was plugged in, but my 2008 Mac Pro ALWAYS chimes through the internal speak when booting, no matter what.

    Loud and annoying, especially late at night when the kid is asleep in the next room.
     
  6. treo360 macrumors member

    Joined:
    Jun 22, 2009
    #6
    heh, I have my Macpro 3.1 plugged in to 5.1 system, internal volume is down to mute so when it starts up I don't get the startup chime.
     
  7. lannister80 macrumors 6502

    lannister80

    Joined:
    Apr 7, 2009
    Location:
    Chicagoland
    #7
    I didn't know there were separate volume controls for different outputs. I'll have to check that out.
     
  8. treo360 macrumors member

    Joined:
    Jun 22, 2009
    #8
    The thing is you have to make sure you have the internal volume shut own first, before you enable digital output, because after you do the volume control is grayed out.
     

Share This Page