Disabling Macros in MS word 2004???

Discussion in 'Windows, Linux & Others on the Mac' started by millerb, Oct 28, 2007.

  1. millerb macrumors newbie

    Joined:
    Oct 28, 2007
    #1
    Hey all,

    So for the longest time my files in Word 2004 for MAC have had MACRO :confused: saved within them. This doesn't really cause any problem for me on my system but when I try to email any word files to anyone it just wont work. The file will be blocked by my hotmail account, and if I use another account that allows me to send it it usually won't work right on the other person's computer. :mad: When I try to make them .RTF files... they usually don't display right for other Word users, although they look fine to me, especially when they have some elements like shapes and text boxes within them.

    Does anyone know HOW I can get these things to stop saving in every single word file I make? This wasn't always this way.... I think I just accidentally recorded a macro a while back, without knowing what they were or what the consequences might be.

    Again, I just need to disable ALL macros. If you know how to do this I'd be greatful if you could share with me.

    Thanks,

    Ben :(
     
  2. Thornie macrumors member

    Joined:
    Oct 25, 2006
    Location:
    NY, NY
    #2
    I am having the same problem, can anyone help?

    I never explicitly tell word to insert a macro, yet I'll have a few docs that will magically have them. I can't copy and paste to a new document because that just copies the macro along with it. Any ideas as to why Word is acting like this?

    P.S> I really wish my office would greenlight switching to iWork 08, it would make like 1000 times easier.
     
  3. ProblemChild macrumors newbie

    Joined:
    Mar 13, 2008
    #3
    Hi both
    Don't know whether this'll be any use given your post is coming up to six months old but I have a solution.
    You have the Word '04 Macro virus, which is being detected by others e-mail av filters. Luckily this is quite easy to get rid of, but quite difficult to stop recurring. To remove it, quit your Word and go to Home folder -> Documents -> Microsoft User Data and delete the file called Normal, or Normal.dot
    When you next open Word Normal.dot will be re-created as a clean file.
    As for stopping it coming back, don't open any file you have EVER saved using your corrupted copy of Word. Obviously this is likely to be quite a lot of documents but there is a way to get them back. Before opening anything you have saved, open a New Word document from the Project Gallery and check that you could use Macros by looking to see if the Macro option under Tools is available. If its grayed out, then go back and delete your Normal.dot
    If you can use macros then open the document you want to recover and open it choosing to Disable Macros. Clicking enable macros will bring the problem back. However once the document is open in Read-Only format you can copy and paste its contents into the clean blank document and save it with the original file name, adding the word 'clean' if you want to save it to the same location. Then go into the folder where the file is saved and delete the old one and rename the original and there you go.
    Unfortunately I don't know of any way to do this en mass but there may be a way.
    Hope that helps
     
  4. refractions macrumors newbie

    Joined:
    Feb 24, 2010
    Location:
    Melbourne, Australia
    #4
    to beat the word 04 macro virus!

    Dear ProblemChild,

    thanks for your fix - excellent! One slight alteration I'd suggest. You don't have to copy and paste all the documents you've ever created into new, blank documents.
    I deleted the normal.dot file, as you suggested, and then used an antivirus program (Avast!, in my case) to clean ALL of the infected files (making sure to locate every single one). This, coupled with deleting the Normal.dot file, seems to have deleted the virus. Afterwards I could open all my old files and send files to other people with no problems.

    I hope this helps someone else.
     

Share This Page