Disabling sleep mode

Discussion in 'OS X El Capitan (10.11)' started by Huiu, Oct 23, 2015.

  1. Huiu macrumors member

    Joined:
    May 22, 2012
    #1
    I want to disable the sleep mode in el capitan, which is especially annoying while trying to download a bigger file. In energy savers preferences and safety preferences I disable everything that is connected with an automatic sleep mode, but nevertheless, after some minutes the sleep mode is activated and my downloads stopped. Is there any option I have not seen so far?
     
  2. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #2
    I guess, such settings could help you out.
    1. Always keep the screen on.
    2. If you don't like 1, then "Prevent computer from sleeping automatically when the display is off"
    3. Don't put hard disks to sleep when possible.
    4. Wake for Wi-Fi network access.
    5. Enable power nap while plugged into a power adapter.
    Regards.
     
  3. Huiu thread starter macrumors member

    Joined:
    May 22, 2012
    #3
    Thanks for your suggestions. I've already chosen all these options, but the sleep mode is nonetheless activated and the downloads stop.
     
  4. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #4
    Well. Uh, let me do a test this night.
    Strange. Or apple just want to push their environmental friendly plan to every corner, and prevent users from using computer like that? :confused:
     
  5. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #5
    odd. you've got sleep set to 'never'? i've always done that, and it always works. you've unchecked 'schedule' settings? meanwhile, you could try deleting (in Home>Library>Preferences) com.apple.systempreferences.plist (or move it to the desktop); reboot, note you may have to redo other system pref settings...
     
  6. ABC5S macrumors 68040

    ABC5S

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #6
    You can turn display off : NEVER as mentioned above ?

    Screen Shot 2015-10-23 at 9.04.16 AM.png
     
  7. Huiu thread starter macrumors member

    Joined:
    May 22, 2012
    #7
    After rebooting it's now working. Thanks to all of you. :)
     
  8. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #8
    I am burning my MacBook Air to try to prove this. ;)
    Anyway, congratulations.
     
  9. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #9
    Test result is out.
    When using my setting set, Mac will not automatically sleep.
    Prove that this way is the best way to prevent it from sleeping.
    Maybe turning off screen is possible.
     
  10. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #10

Share This Page