Disappearing bootcamp partition after defrag

Discussion in 'macOS' started by mustgroove, Aug 30, 2007.

  1. mustgroove macrumors regular

    Joined:
    Aug 14, 2006
    #1
    Last night I defragd my Bootcamp partition using Raxco Perfectdisk 8.0, and it went fine... it did an offline defrag of system files & pagefile first (after a reboot), then it did a Smartplace defrag of all the other files...

    Now, OS X doesn't recognise the partition as being present... Disk Utility shows an extra partition called "disk0s3", which is unmounted (greyed out), and the filesystem is listed as "Microsoft Basic Data"...

    But if I reboot the machine and hold down Alt, the Windows partition is recognised, boots properly, and works 100% fine... MacDrive also recognises the OS X partition fine and everything is totally fine...

    So is there an easy, painless & safe way to make OS X recognise the Windows partition as a proper NTFS partition and mount it again? I tried just highlighting it in Disk Utility and selecting "Mount" from the File menu, but it doesn't work...

    Any help would be appreciated :)
     
  2. mustgroove thread starter macrumors regular

    Joined:
    Aug 14, 2006
    #2
    O.P.

    Just tried my usual method for fixing Bootcamp-related problems - create an image of the Bootcamp partition (using DriveImage XML), use the Bootcamp Utility to restore OS X to a single partition, then recreate the Bootcamp partition and restore the DriveImage XML image... I've done this a few times before and it works like a charm...

    But... this time, Bootcamp Utility consolidated the OS X partition to take up the whole drive again, but now when I try and create the Bootcamp partition again it gives an error, saying something like:

    "Creating partition failed because some files could not be moved"... it then suggests I backup the machine and reformat?!?!?!

    Does anyone have any tips on how to fix this without having to reinstall the entire OS?
     
  3. danembraceddc macrumors newbie

    Joined:
    Sep 6, 2007
    #3
    Sadly the only way I've found to fix this is by doing the same thing that caused your first problem. Defrag.

    I've had this happen several times, and was able to fix it once with Disk Utility off the install dvd, but after that it required a defrag of the Hard drive. iDefrag is an excellent choice and has served me well thus far.
     

Share This Page