Disappearing iTunes TV Shows

Discussion in 'Mac Apps and Mac App Store' started by ghall, May 1, 2011.

  1. ghall macrumors 68040

    ghall

    Joined:
    Jun 27, 2006
    Location:
    Rhode Island
    #1
    Something odd happened with my iTunes library. A few random TV shows seem to have disappeared. They're still listed in my library but they have the little ! icon to show that the file can't be found, and when I try to locate it I can't find it anywhere. It's like it has been deleted from my hard drive. It seems very random (2 episodes of Doctor Who, 1 episode of Futurama, etc), and seems to only affect TV shows (all my music, apps, and movies are intact).

    I'm not too worried about recovering the files because I keep a regular backup of my entire hard drive, but I am a little concerned. I only delete TV shows from iTunes after I've copied them to another drive, and even then I only do that with entire shows so random episodes would not be missing. Also, this problem seems limited to iTunes as I have not noticed any other missing files on my system (though that doesn't necessarily mean there aren't any).

    Any ideas what could be causing this? The hard drive is fairly recent (3 months old) and checks out in disk utility so I'm leaning towards ruling that out. I'm running iTunes 10.2.2 under Mac OS X Snow Leopard 10.6.7 on a 2GHz Intel Core Duo MacBook Pro.
     
  2. ghall thread starter macrumors 68040

    ghall

    Joined:
    Jun 27, 2006
    Location:
    Rhode Island
    #2
    I may have figured it out. I just went to restore the missing files with Time Machine and they were never backed up for some reason, so they were never restored when I replaced my hard drive 3 months ago. So Time Machine bug?
     
  3. trip1ex macrumors 68000

    Joined:
    Jan 10, 2008
  4. ghall, May 1, 2011
    Last edited: May 1, 2011

    ghall thread starter macrumors 68040

    ghall

    Joined:
    Jun 27, 2006
    Location:
    Rhode Island
    #4
    Ok so I've been working on the problem. For some reason these files never backed up. Thankfully I still have my old hard drive and I can still access it but the problem files throw up the lovely Error -36 when I try to copy them and none of the fixes I have found online have helped. I probably spent an hour in Terminal trying to copy them that way as well.

    Edit: I should add that the files play fine directly from the hard drive.
     

Share This Page