Disappearing Superdrive mount

Discussion in 'MacBook Pro' started by jimkoke, Mar 17, 2014.

  1. jimkoke, Mar 17, 2014
    Last edited: Mar 17, 2014

    jimkoke macrumors newbie

    Joined:
    Feb 5, 2009
    #1
    I've created this problem for myself and don't know how to fix it.

    I've got an MBP RD and an external superdrive.

    I have several data CDs that I need to back up, so I decided to just copy them to my local hard drive. I created a parent folder for all of the CDs and then a folder for the first one. I mounted the first CD in the superdrive, it mounted, the disk name appeared under the DEVICES section with its "eject" icon.

    Then I made my mistake (I think). I dragged the disk name from the DEVICES list to the folder I created for it. All of the files were copied from the CD to my hard drive, however, the disk name and eject icon had disappeared from the DEVICES list.

    I waited for all copying to complete, and unplugged the superdrive and replugged it in. The superdrive made all the right noises, but the disk name never appeared in the DEVICES list as expected. I tried this several times.

    I ran the Disk Utility program and it saw the CD, mounted as I would expect it to and I could eject it, and did so.

    I repeated the process with the next disk however I opened the CD folder and then dragged and dropped its contents, which worked perfectly, and its name remained in the DEVICES list, from where I then ejected the disk.

    I then tried mounting the first CD and it mounted just as before - never appeared in Finder but did in Disk Utility. Since it does not appear in Finder, I have no way, that I know of, to use the disk.

    I have noticed that when I mount a CD that behaves properly, Disk Utility shows two entries for the disk: one under SuperDrive and one as a sibling to SuperDrive. The failing CD has had one or both at various times, in neither case has that CD mounted under Finder.

    In summary - I have a CD that mounts *somewhere* on the Mac, just not under the DEVICES list in Finder and I would like to fix this issue.

    So - if you can follow what I've done, any ideas as to what happened?
     
  2. jimkoke thread starter macrumors newbie

    Joined:
    Feb 5, 2009
    #3

Share This Page