Disc Not Ejected Properly Messages

Discussion in 'OS X El Capitan (10.11)' started by sks109, Oct 4, 2015.

  1. sks109 macrumors newbie

    Joined:
    Jul 9, 2014
    #1
    Tearing my hair out here, been using my 1TB WD for last two years as time machine with no problems and very fast.
    Just updated to El Capitan and try to backup but it runs for 10 minutes or so and then I get the message disc not ejected properly. However many times I try this it keeps kicking it out. fine before upgrade but now shortly after, no joy. Tried different ports but all give the same result. Any help most grateful.

    The other strange action is when the mac wakes, keyboard typing seems to go wild with random characters as if the keys are stuck. I have to restart to et back to normal. Thins getting really annoying.
     
  2. neliason macrumors member

    Joined:
    Oct 1, 2015
    #2
    I have the same problem. I have a USB drive connected directly to my iMac, mid 2011. It has a seperate power supply. I have another USB connected to a Thunderbolt dock. The drive is powered solely by USB, but the dock itself has a seperate power supply. These drives are both used as Time Machine drives. Both have at various times disconnected.

    I have another USB drive connected to the dock. I don't think it has yet disconnected. I'm going to pay attention to that going forward. I don't know how to fix the problem and don't know if it is a USB problem or maybe it is Time Machine related. I did an SMC reset and it didn't make a difference. Everything worked fine on Yosemite.
     

Share This Page