Disc Utility Not Opening

Discussion in 'macOS' started by macro, Sep 9, 2008.

  1. macro macrumors member

    Joined:
    Dec 15, 2007
    #1
    My "Disc Utility" will bring up its window on my desk top but it just keeps rotating the whirly symbol and will not fully open. Just keeps searching and searching. When I tried to report this to Apple the same thing happened with the Apple Reporting window. Just kept sending and never stopped. I let both go for 18-20 minutes and nothing. this means I can't repair permissions or anything else.

    Before this my optical drive would not open either and I had to remove it and manually open the door and get the CD out. I don't know if this is a cause/effect relationship for the above problems. I wore a grounding strap as I always do whether Mac or PC. Any thoughts or suggestions?
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    If your optical drive works now, I'd suggest booting off of your OS X DVD and using disk utility there. It sounds like your permission are borked or there is a hard drive defect that needs immediate help.

    If your optical drive doesn't work, disconnect it from the computer. I have had similar problem with Disk Utility not operating if it saw there was a drive but couldn't get a status report from it.

    Worse case is to find an Apple Store or Apple Repair Center and have them run some diagnostics and see if they can fix it.

    TEG
     
  3. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #3
    Single user mode and repair drive with fsck

    Check console.app to see what the error logs are saying, if you get a bunch of spinning balls could be the drive going bad or something like samba creating a bunch of errors and stalling the machine.
     
  4. macro thread starter macrumors member

    Joined:
    Dec 15, 2007
    #4
    The optical drive is not working from the keyboard, the drive won't respond. As I cannot get disc utility to work I am not sure how to proceed.

    Sunbaked, I am new to Mac and am not sure what your abbreviations are referring to. Thanks to both of you for responding.

    I purchased a couple new drives from New Egg-Pioneer drives. I am not an amateur at working the internals so will install these as I need two drives for my photography. However, I think I need to be sure what the hdd is doing before I do any install of new hardware.

    Is going to Apple what I need? Or, is there something I can do to ferret out the problem as disc utility does not work. I am just trying to sort out the two replies.

    My photos are, for now, on another computer so I will only lose the personal data if I reinstall Leopard. That is a pain in the Levi's. Any help is appreciated.

    I did a search on Apple support but you know how that goes. Nothing in an answer specific to my problem.

    Can I answer any questions that would help any one here to more specifically narrow an answer to this problem?
     
  5. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #5
    Click on the desktop, when the menu bar at the top say Finder ...

    Type in "single user mode", and follow the directions for "Starting up in single-user mode"

    When you start up in single user mode, follow the directions for running "fsck"

    fsck = disk utility for repairing the drive

    ---

    Note that it a multi pass process -- so run it again and again if it doesn't come back with a clean pass, or until it stops repairing or states that it can't repair the drive.
     
  6. macro thread starter macrumors member

    Joined:
    Dec 15, 2007
    #6
    Click on the desktop? Not sure what you are asking me to do. I am fairly new to Mac, coming over from PC. I have been pretty good, as an amateur, in working out registry problems, successfully, on my PC's. The finder, whether in the top or bottom of the Mac, is easy to see. When I click on the desktop nothing comes up as it did in PC.

    I bought two new drives that I need to install to remedy this problem if needs be. I have them on hand. Can someone help us with this barrier? I am grateful but find the answers to terse in my ignorance.
     

Share This Page