Disk cannot be partitioned...

Discussion in 'Windows, Linux & Others on the Mac' started by webteeth, Aug 29, 2007.

  1. webteeth macrumors member


    Aug 29, 2007
    Ontario, Canada

    I'm trying to install Boot Camp on my Intel Core 2 Duo iMac. I have the latest version of Boot Camp which I recently upgraded from 1.2. I had Windows installed on my Mac previously, but deleted that partition through Boot Camp Assistant. Now, when I try to partition the drive, I get the error...

    "The disk cannot be partitioned because some files cannot be moved

    Back up the disk and use Disk Utility to format it as a single Mac OS Extended (Journaled) volume. Restore your information to the disk and try using Boot Camp Assistant again."

    However, the disk is ALREADY formatted as "Mac OS Extended (Journaled)". I have repaired the disk through Disk Utility, and it still won't partition.

    Does anyone here in the MacRumors forum have a potential solution for the problem? Help would be greatly appreciated.

    Thanks :)
  2. fishkorp macrumors 68020


    Apr 10, 2006
    Ellicott City, MD
    apps like the adobe suite sometimes do this, leave files that can't be moved. you can try a 3rd party application like iDefrag to try to fix the problem, but i was never successful in getting around this error.
  3. Chafka macrumors member

    Aug 29, 2007
    I had this problem when I tried to install Boot Camp 1.4 also. I had parallels installed along with a bunch of other stuff that I ended up backing up and nuking (parallels was deleted and not backed up). The drive needs enough space to move stuff around and then resize and make the partition. I ended up with only 40 GB of my 120 GB drive used and then it worked - I did not try various sizes between 80 GB and 40 GB. Also, my windows install was only 20GB.


Share This Page