Disk corruption.. need help! - Invalid sector size: 0

Discussion in 'Windows, Linux & Others on the Mac' started by manuH, Jan 24, 2013.

  1. manuH macrumors newbie

    Oct 26, 2012
    I use osx 10.8 and WIn7 with refit boot, a SSD with both systems and a 1To Samsung HDD formatted to FAT for being used by both systems, and that worked fine for 2 month..

    suddenly, after I rebooted from win7 to osx system, the 1To Samsung appears as RAW, :eek:
    when I launch disk utility it says "Invalid sector size: 0", and that it could not repair this disk and it has to be formatted..

    any advices ?
    what disk utility would you recommand ?
    is disk warrior only for HFS or it also works with FAT ?

    Vérification du volume « disk1s2 »
    Vérification du système de fichiers
    ** /dev/disk1s2
    Invalid sector size: 0
    Erreur : Ce disque doit être réparé. Cliquez sur Réparer le disque
    Vérifier et réparer le volume « disk1s2 »
    Vérification du système de fichiers
    ** /dev/disk1s2
    Invalid sector size: 0
    Réparation du volume terminée.
    Mise à jour des partitions de prise en charge du démarrage pour le volume, comme requis.
    Erreur : Utilitaire de disque ne peut pas réparer ce disqu...rmatez le disque, puis restaurez vos fichiers sauvegardés.
  2. SandboxGeneral, Jan 24, 2013
    Last edited: Jan 31, 2013

    SandboxGeneral Moderator


    Staff Member

    Sep 8, 2010
    Orbiting a G-type Main Sequence Star
    If it's a bad sector on the HDD I recommend you use a PC DOS-based program called Spinrite which is a maintenance utility and data recovery utility. You have to have an IBM-PC in order to use it though. You take the HDD out of the Mac and connect it to the IBM-PC and run the program. Below is my old MBP HDD in a Dell PC with Spinrite working on it.



  3. justperry macrumors 604


    Aug 10, 2007
    In the core of a black hole.
    I would first try to repair it in windows, Diskwarrior is only for HFS afaik.
  4. manuH thread starter macrumors newbie

    Oct 26, 2012
    i tried diskwarrior 4, but it seems to work only with hfs,
    mine is FAT

    actually i'm running Get Data Back. Actually scanning for a few hours. I will tell you about the results later.
  5. manuH thread starter macrumors newbie

    Oct 26, 2012
  6. ACagliano macrumors newbie

    May 10, 2012
    Do you have version of OS X with Recovery HD? Anything later than 10.7 creates a separate partition and you can boot into it and repair from there.

    Hold option while booting and select Recovery HD.
  7. AppleMacFinder macrumors 6502a


    Dec 7, 2009

Share This Page