Disk I/O Error - Persists after Apple repairs MBP

Discussion in 'MacBook Pro' started by tbeyett, Jan 3, 2010.

  1. tbeyett macrumors newbie

    Joined:
    Jan 3, 2010
    #1
    Hey,

    A few weeks ago my MBP (13 in, 2.26GHz Core 2 Duo, 160GB HDD, 4GB RAM, OS X 10.6.2) was telling me that I was unable to save to my internal HDD because it was "full or write protected". After a restart, I was able to save. About an hour later I encountered the same problem. I restarted again only to have my system hang up at the screen with the apple logo and the spinner at the bottom. I let it sit for nearly 20 min and it never booted. I attempted a disk repair, permission repair, reinstalling the OS, erasing the drive, partitioning the drive, booting in safe mode, fsck, and restoring from a time machine backup without any success. In verbose mode, I kept getting a "disk I/O error". I ended up installing the OS on an external USB drive and booting from that and everything worked fine, leading me to believe that the internal drive was dead or dying.

    My laptop was under warranty so I called up Apple and informed them of the situation. I sent them my laptop to get repaired. I had it back in a few days. I looked at the service report that was in the box and saw that they replaced the internal HDD with a new one with 10.6.1 on it. It also said that my mac passes all hardware diagnostic tests. I booted up my laptop and it failed to boot up. Again, it was getting stuck at the screen with the apple logo and the spinning gear. I tried all of the things that I tried the first time (see above) with not success.I checked and I was still getting a "disk I/O error". I don't think that the internal drive is failing because it's brand new and I can boot from my external and use finder to navigate through the files on my internal drive (and even open them up).

    I am completely out of ideas. I plan on calling Apple back up but would like to see if anyone online can help seeing as Apple was unsuccessful the first time. It appears that the drive is functioning properly but I can't boot from it.
     
  2. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #2
    Based on your description, your computer was sent to an Apple central repair facility. The notes on the "repair confirmation" page on mail-in repairs are not always accurate.

    For example, I recently sent a computer in; they stated that they had erased the hard drive. What a surprise, all the data was still here. (However, in our situation, they actually fixed the problem.)

    I'm not sure whether or not they replaced your hard drive, but if you're seeing an I/O error in verbose mode, the chances of it being a software issue are close to nil.

    Send it back, they'll fix it right the second time.
     
  3. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #3
    Apologies for the double-post.

    In my experience of sending many computers in for repairs, Apple's central repair facility will NEVER transfer files from a failing hard drive to a new hard drive.

    You mentioned that you could boot externally and see all your files on the internal drive. If your files are still there, Apple definitely did not replace your drive.

    Call 800-APL-CARE again and request that they do the repair right.
     
  4. tbeyett thread starter macrumors newbie

    Joined:
    Jan 3, 2010
    #4
    A little clarification - I can see the files on the HDD but they are just the OS files (they claim that they put in a new HDD with nothing but the OS on it). Could it be the HDD cable? I doubt that Apple replaces both the HDD and the cable.
     
  5. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #5
    No, Apple would not have replaced the cable. It's possible but unlikely that the cable is at fault. In almost every scenario where a Disk I/O error is shown, replacing the hard drive fixes it completely. That's an odd situation.

    You might try reinstalling the operating system (erasing the drive and starting over). But that really shouldn't be necessary—especially with a brand new drive.

    If an erase and install doesn't take care of it, I'm afraid Apple will need to take another look at it.
     
  6. tbeyett thread starter macrumors newbie

    Joined:
    Jan 3, 2010
    #6
    I've attempted to reinstall the OS but keep getting messages that the installation has failed. I'm also unable to erase the disk because it is mounted. The only way I can unmount it is through the terminal and then I still get the error. Could this be a logic board problem?
     
  7. MacsOnAnabolics macrumors regular

    MacsOnAnabolics

    Joined:
    Jul 31, 2009
    Location:
    Rancho Cucamonga, CA
    #7
    You need to delete some programs or buy a bigger hard drive...
     
  8. tbeyett thread starter macrumors newbie

    Joined:
    Jan 3, 2010
    #8
    It's a 160GB drive and I have over 100GB free on it.
     

Share This Page