Disk Locked; cannot Re-install Osx

GLRico

macrumors newbie
Original poster
Jun 7, 2017
7
1
Had a strange issue with my Mac where the password box was not popping up and I couldn't log-in. I think it is 2014 model btw. So I tried to delete the HD and reinstall. I think I also have restored the 1.51 Gb OSX base system back on and it no longer appears as an external disk. It also does not let me delete the HD in disk utility now and only gives me the first aid option not grayed out which quickly reports no issues.

Real Problem:
When trying to reinstall the HD is grayed out and it says "this HD is locked" preventing me from reinstalling.

I found some posts and tried to apply what I read; when I use the terminal and command: diskutil cs list
It replies with : no CoreStorage Logical groups found

When I use command: diskutil list
Reply is:
/dev/disk0 (internal, physics):
#: Type Name Size Identifier
0: GUID_partition 251.0Gb disk0
1: EFI EFI 209.7Mb disk0s1
2: Apple_HFS OS X Base System 250.1Gb disk0s2

/dev/disk1 (disk image):
#: Type Name Size Identifier
1: untitled. +5.2Mb Disk1

It goes on for another 15 disk to 16 all maker identical to disk1.

Also I cannot boot the Mac; it goes straight to recovery options and if I try starting it with r+CDM held it actually does nothing it seems. Any help would be very very greatly appreciated please.
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,467
24,212
If you try right-click the volume in Disk Utility and select Unlock, then enter your password, does this now allow you to install macOS? Hopefully it's as simple as that. :)

If so: unlock the disk, format, then install macOS.
 

GLRico

macrumors newbie
Original poster
Jun 7, 2017
7
1
In disk utility it is not letting me bring up any kind of menu by click on the drives.

Most of the options other than first aid at the top are grayed out. In disk utility what it shows me is:

APPLE SSD SM0256G Media (251Gb PCI Internal Physical Disk)
<
OS X Bass System (250.14Gb PCI Internal Volune Mac OS Extended)
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,467
24,212
In disk utility it is not letting me bring up any kind of menu by click on the drives.

Most of the options other than first aid at the top are grayed out. In disk utility what it shows me is:

APPLE SSD SM0256G Media (251Gb PCI Internal Physical Disk)
<
OS X Bass System (250.14Gb PCI Internal Volune Mac OS Extended)
Please could you kindly supply a photograph/screenshot of what you see in Disk Utility? Sorry for the inconvenience, just need to be sure what you're seeing and hopefully we'll figure it out. :)
 

GLRico

macrumors newbie
Original poster
Jun 7, 2017
7
1
Please could you kindly supply a photograph/screenshot of what you see in Disk Utility? Sorry for the inconvenience, just need to be sure what you're seeing and hopefully we'll figure it out. :)

I'd like to but when I try uploading a pic from my iPhone it says it is too large. I don't have any URL links or know how to go about that. Is there any information I can look for specifically?
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,467
24,212
I'd like to but when I try uploading a pic from my iPhone it says it is too large. I don't have any URL links or know how to go about that. Is there any information I can look for specifically?
Ah no problem. I should've suggested a few other things anyway.

Please could you hold CMD + ALT/Option + R on startup. This will boot into Internet Recovery. Can you format the Apple SSD in Disk Utility? Not the Macintosh HD volume but the actual listed "Apple SSD"?

If so, after formatting, can you close Disk Utility & reinstall OS X?
 
  • Like
Reactions: SeñorClifton

GLRico

macrumors newbie
Original poster
Jun 7, 2017
7
1
Ok wait think I got it


https://ibb.co/iPEoNa
[doublepost=1496874798][/doublepost]
Ah no problem. I should've suggested a few other things anyway.

Please could you hold CMD + ALT/Option + R on startup. This will boot into Internet Recovery. Can you format the Apple SSD in Disk Utility? Not the Macintosh HD volume but the actual listed "Apple SSD"?

If so, after formatting, can you close Disk Utility & reinstall OS X?
It actually starts up into that mode automatically now; when I try doing it with cmd+r it doesn't work and will never do anything.

When I go to APPLE SSD in Disk Utility it only gives me the options to run first aid or partition. Erase, store, and mount are all grayed out. I don't see anything about formatting and can't bring up any menus by clicking on anything.
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,467
24,212
Ok wait think I got it


https://ibb.co/iPEoNa
[doublepost=1496874798][/doublepost]

It actually starts up into that mode automatically now; when I try doing it with cmd+r it doesn't work and will never do anything.

When I go to APPLE SSS in Disk Utility it only gives me the options to run first aid or partition. Erase, store, and mount are all grayed out. I don't see anything about formatting and can't bring up any menus by clicking on anything.
Just to confirm, you're:

1) Holding CMD + ALT + R on startup (the Alt is very important, as CMD + R will boot into normal recovery)
2) You're selecting the top partition (red) and when you do, the Erase/Partition option is still greyed out?

Screen Shot 2017-06-07 at 23.33.52.png
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,467
24,212
1) I can't do that actually; when I do I get a black monitor screen. Only when I start it up and don't press anything does it bring me to the screen where I can see options like disk utility or reinstall OS X.

2) when Apple SSD is selected partition is not grayed out but erase is.
Oh okay! I'm not sure why it won't boot into internet recovery. Please can you select Partition and see if you can create a new volume that way?
 
  • Like
Reactions: BigHonkingDeal

GLRico

macrumors newbie
Original poster
Jun 7, 2017
7
1
Oh okay! I'm not sure why it won't boot into internet recovery. Please can you select Partition and see if you can create a new volume that way?
https://ibb.co/hPOb8F

Sorry for the confusion but internet recovery does seem to have started; just was much slower. Do I still select partition even with erase and restore options now available?

As for the partition; if I'm to make one what format do I want it in?
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,467
24,212
https://ibb.co/hPOb8F

Sorry for the confusion but internet recovery does seem to have started; just was much slower. Do I still select partition even with erase and restore options now available?

As for the partition; if I'm to make one what format do I want it in?
Ah that's looking better! Just select Erase and ensure the format is Mac OS Extended (Journaled) in GUID. That should be the default setting anyway.

Once it's formatted it'll be able to reinstall macOS from there.
 
  • Like
Reactions: bhrt.rthd123

apicard

macrumors newbie
Jul 30, 2017
1
0
Ah that's looking better! Just select Erase and ensure the format is Mac OS Extended (Journaled) in GUID. That should be the default setting anyway.

Once it's formatted it'll be able to reinstall macOS from there.
Any way to do this without Internet Recovery? I have a similar problem but am using an old 2009 iMac. My primary boot disk somehow was restored as the OS X Base System and now I can’t boot past recovery mode. I need to wipe everything and reinstall MacOS High Sierra. Thanks.
 

Nikko123

macrumors newbie
Apr 17, 2018
1
0
Please help me, I think my Mac doesn't have features of INTERNET RECOVERY what should I do?
 

careye

macrumors newbie
Jun 9, 2018
1
0
Please help me, I think my Mac doesn't have features of INTERNET RECOVERY what should I do?
Hi - It's been a while since you've posted this - hope you figured it out ok. If not, here's what I learned - I had the very same problem including the drive information shown in pictures from others.

You have to be hardwired, NOT wifi, when you reinstall the OS from the internet. I'm quite novice but what I think happens is that the wifi connection (or ability to connect via wifi) comes later in the boot sequence. I hardwired my machine and was able to go from there. The part with the spinning globe went from about 12 minutes to about 3, I then had to partition the hard drive (journaling enabled as it will tell you when you first try to load the OS - so you may have to back track to the disk utility), then the reinstall OS works slick as can be. I'm not quite done yet but the hard drive was available where it wasn't before and it's now counting down on the installation.

MOST of the instructions on the Apple site for this were great and very helpful, but they never mentioned being connected through cable to the internet. Seems a critical piece of information missing.

Good luck!
 

jucava85

macrumors newbie
Jan 8, 2019
3
0
Can someone PLEASE help me? I have a very similar problem. I was using my macbook pro and it froze so I turned it off, been having issues ever since. I get the kernel panic error, I am able to start up in Internet Recovery, but I'm not sure where to go from there. When I try to reinstall OS, it says my HD is locked. I go to the HD in Disk Utility and it does not let me double click or right click the HD to unlock. I don't have any back ups to use and I don't want to lose all of the stuff I have stored on my HD. Is there any way to resolve the issue without losing all of my stuff? Any help would be greatly appreciated!
 

Gabig

macrumors newbie
Feb 14, 2019
2
0
Ah that's looking better! Just select Erase and ensure the format is Mac OS Extended (Journaled) in GUID. That should be the default setting anyway.

Once it's formatted it'll be able to reinstall macOS from there.

Thanks i've the same issue, AND with Alt+cdm+r Is solve!!!
[doublepost=1550184380][/doublepost]
Can someone PLEASE help me? I have a very similar problem. I was using my macbook pro and it froze so I turned it off, been having issues ever since. I get the kernel panic error, I am able to start up in Internet Recovery, but I'm not sure where to go from there. When I try to reinstall OS, it says my HD is locked. I go to the HD in Disk Utility and it does not let me double click or right click the HD to unlock. I don't have any back ups to use and I don't want to lose all of the stuff I have stored on my HD. Is there any way to resolve the issue without losing all of my stuff? Any help would be greatly appreciated!
Try Alt+cdm+r
Then érase your disk
Then reinstala Mojave (not sietra)
 

SLiM_92

macrumors newbie
Feb 19, 2019
1
0
Thanks i've the same issue, AND with Alt+cdm+r Is solve!!!
[doublepost=1550184380][/doublepost]
Try Alt+cdm+r
Then érase your disk
Then reinstala Mojave (not sietra)
Hello, i have followed this to the T and still cant do anything, the only option i have is first aid or partition, when i go into partition i am able to click the + button but nothing happens, i have tried this in both the ST3100528ASQ Media and the OS X Base System

thanks for any recommendations
 

Angelrios

macrumors newbie
Jun 20, 2019
1
0
Thanks i've the same issue, AND with Alt+cdm+r Is solve!!!
[doublepost=1550184380][/doublepost]
Try Alt+cdm+r
Then érase your disk
Then reinstala Mojave (not sietra)
If I follow these step will it erase all my data? I do not have backup