Disk not ejected properly

Discussion in 'OS X Mavericks (10.9)' started by Sandman77, Feb 4, 2014.

  1. Sandman77 macrumors newbie

    Joined:
    Sep 29, 2013
    #1
    I have an external USB powered HDD attached directly to a USB3 port on my 2012 mac mini. I never eject this drive as it is used daily and is where my media is stored. It seems that every time my mac goes to sleep and is woken up I get the above error message. It is really annoying because my mac is used purely as a plex server/player and is controlled almost exclusively with a remote control and I need to dig out the Bluetooth mouse to get rid of the error message.

    Anyone have any ideas how I can prevent this from happening?
     
  2. Sandman77 thread starter macrumors newbie

    Joined:
    Sep 29, 2013
    #2
    509 views and nobody has experienced the same issue? I guess the problem is in my setup somewhere.
     
  3. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
  4. HenryDJP macrumors 603

    Joined:
    Nov 25, 2012
    Location:
    United States
    #4
    Also change your cable, you may have a small break in it causing connection loss.
     
  5. Oracle9999 macrumors newbie

    Joined:
    Aug 4, 2012
    #5
    Sandman77 I have the same issue as the one that you described - sadly I couldn't fix it yet.
     
  6. Sandman77 thread starter macrumors newbie

    Joined:
    Sep 29, 2013
    #6
    I did the SMC reset last night so I will see if I get the message again when I turn the mac on tonight (UK time).
    If that doesn't work I will try a different USB cable. The one I am using is a cheap one from amazon. The one supplied with the HDD wasn't long enough to put the HDD far enough away so it doesn't cause interference with my USB wireless dongle (I dont understand why a USB3 HDD would affect this in the first place, but trust me it did).
     
  7. Sandman77 thread starter macrumors newbie

    Joined:
    Sep 29, 2013
    #7
    No messages today so it looks like resetting the smc may have solved the problem.
     
  8. Schoey S macrumors newbie

    Joined:
    Apr 22, 2014
    #8
    That was my issue and it took me ages because we got so used to just using usb cables that we think its fail proof, I went and bought a new one and it still didnt work, only after i purchased a good quality cable only then it resolved my issue, so the only reason i can think is that between the qualities of cables we can buy there is transfer quality issue, on cheaper cables it is not as good as on quality cable.
     
  9. coldjeanzzz macrumors 6502a

    Joined:
    Nov 4, 2012
    #9
    i've learned not to take it personally, this forum has perhaps the worst view to reply ratio i've ever seen.
     
  10. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #10
  11. JohnColorado macrumors newbie

    Joined:
    Nov 25, 2011
    #11
    Uncheck 'Put Hard Disks to Sleep'

    I have been having this same problem with a Seagate USB drive.

    Have not yet verified if this works for me, but one solution getting some people results is to open System Preferences > Energy Saver, then UNcheck the box that says "Put hard disks to sleep when possible". This needs to be done for both the 'Battery' and 'Power Adapter' modes.

    From https://discussions.apple.com/thread/5678720?tstart=0

    Good luck.
     
  12. laracroft123 macrumors newbie

    Joined:
    Oct 20, 2014
    #12
    Power-down for at least 2 hours

    RE: New Mac Pro (late 2013) with LaCie externals: 2x3TB, 1x1TB (USB3), and 2x12TB LaCie 2BIG (each RAID 0 on Thunderbolt 2).

    The 12TB drives were behaving perfectly when brand new (about 3 weeks old now). Then, Final Cut Pro with a certain MOTIONVFX.com plug-in occasionally caused my system to crash and reboot automatically. As a result, finder prefs (minimally) got corrupted and I couldn't even dup or delete a file or folder. PLUS, eventually, the 12's would no longer sleep with the computer and then get ejected when the Mac slept for an extended period of time and when the Mac woke up, it produced the dreaded, "DISK NOT EJECTED PROPERLY" message for BOTH 12's.

    I tried everything: zapping PRAM, resetting SMC, rebooting, repairing permissions...Nothing worked. LaCie: No help, although they offered to send new Thunderbolt cables.

    I had the same drive-not-sleeping problem with my Mac Mini for a while, and that inexplicably went away recently.

    Sooooo... Here's how mine got fixed. Hope it works for you...

    Last night there was a car accident (somewhere) at 2:45AM and for 2-1/2 hours we had a power outage in the entire area. At 6AM I woke the computer and the drives were once again working perfectly (and not getting improperly ejected).


    The one thing I hadn't tried was shutting down the Mac PRO for an extended period (probably the same extended period of simple sleep that caused the ejection). The Mac Mini's drive-sleep problem probably also went away when it was powered down recently for lack of use.

    So try it: Power-down for at least 2 hours.
     
  13. Bluemeanie1976 macrumors 6502a

    Bluemeanie1976

    Joined:
    Nov 1, 2009
    Location:
    Veliko Tarnovo, Bulgaria
    #13
    I'm having this problem on my late 2010 Air. With a drive attached, (with integral cable), and you close the lid, or it goes to sleep, it will have the 'disk not ejected properly' message when you awaken.

    I should not really have to spend 2 bucks on an issue that should be solved by the OS as is.
     
  14. Aussie Ziggie macrumors newbie

    Joined:
    Dec 27, 2014
    #14
    Same Issue re "Failure to Eject Disk Properly" Messages

    Hi, Sandman,
    Just new to MacRumors so not sure how all this works. I just wanted to reply that I have had the same issue. OS 10.10.1 on new MacBook Air with new Seagate and older WD 1TB external HDs used as alternating backups with Time Machine. After waking Mac up from Sleep I often got those "failure to eject disk properly" messages. Saw a suggestion in a post for a related issue and so went into Energy Saver preferences and unselected "put hard disks to sleep when possible" for both battery and mains modes, Haven't had the issue since.
    Cheers,
    Aussie Ziggie
     
  15. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #15
    The Energy Saver workaround will be good for some cases.

    Some hardware mixes will be OK with one type of file system, not OK with a different type.

    Some types of failure will be more likely where, say, a peripheral USB hub is used.

    Some hardware mixes will be good with sleep but fail with safe sleep.

    Feedback to Apple; feedback to the drive manufacturer. Wish for, but do not expect, a fix from one or both.

    Technical

    hdparm on OS X – Server Faultmy answer. If you're lucky, you'll have SpindownHD, but don't expect it to report things perfectly for modern hardware (example attached).
     

    Attached Files:

  16. Gochugogi macrumors regular

    Gochugogi

    Joined:
    Oct 27, 2013
    Location:
    Sandwich Isles
    #16
    I too have been suffering the "failure to eject disk properly" warning for a USB drive connected to my 2009 Mac Pro. It actually wakes up from sleep to inform me, sometimes every few minutes!

    I restarted and the same. So I used Disk Utility (recovery mode) to repair the drive and permissions and topped it off with the 4-finger salute (Command-shift-PR) at restart and it returned to normal. It's been fine for 24 hours. I don't know which fix worked but it's fine now after many days of that drive warning BS.
     
  17. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #17
    Alerts from Finder

    The shouldn't view those alerts as BS. They effectively prompted you to take appropriate actions … actions that help to reduce the risk of damage to your data.

    Incidentally, I don't imagine any type of problem with file permissions contributing to an improper eject of a volume or drive.
     
  18. Gochugogi macrumors regular

    Gochugogi

    Joined:
    Oct 27, 2013
    Location:
    Sandwich Isles
    #18
    What's odd is this only happens in Mavericks. I have 10.85 and 10.68 on separate volumes and they have never issued the "drive not properly ejected" warning. I would stick with 10.85 if it weren't for certain apps I need to run.
     
  19. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #19
    Environment

    What make and model is the drive, and what's its firmware?

    USB 2.0 or 3.0?

    Is anything else on the same USB controller?
     
  20. richsad macrumors newbie

    Joined:
    Mar 15, 2014
    Location:
    Boston, MA area
    #20
    Having this problem with Yosemite

    I have a MacBook Pro Retina, 15-inch, Early 2013 running Yosemite 10.10.1, 2.7 Core i7, 16GB RAM, internal SSD HD. I have an aging Belkin USB hub which a bunch of USB drives. Some I use for Time Machine, others are cloned drives of past machines with files I access occasionally.

    Boot rom version: MBP101.00EE.B05
    SMC version (system): 2.3f36

    I recently set power settings to put the machine to sleep after set period of time even when plugged in. Now every time I wake it up I get one or more "Disk not ejected properly" messages.

    I'm certainly open to installing jettison but this seems like a fairly serious issue that should be addressed by the OS. I don't know if I accept bad cables or USB hub since they all function well under any other circumstance.

    The drives include a LaCie, WD, iOmega and Maxtor.
     
  21. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #21
    I used to have this problem until I replaced the cable. Problem gone.
     
  22. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #22
    Trouble with USB 2.0

    2.0, I guess. Whilst USB 2.0 is commonplace, it can be troublesome.
     
  23. richsad macrumors newbie

    Joined:
    Mar 15, 2014
    Location:
    Boston, MA area
    #23
    Yes it's USB 2.0

    Yes it's a higher end, powered USB 2.0 hub. It's 5 years old. But what puzzles me is this seems to be a newer problem related to the Mavericks and Yosemite updates. This hub works well in all other respects. I'm always skeptical when an otherwise working device is blamed for a problem that appears with software updates. It could be the device, but it also could be something changed in the system software that made the problem more prevalent.

    I'll try plugging just one of the drives directly into the USB port on the MBP. If there's no problem with that configuration I can accept that buying a newer hub could solve the problem. Although it makes me wonder if investing $2 in Jettison might not be a better solution short term.

    So to be clear, are people with USB 3.0 hubs never experiencing this problem?
     
  24. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #24
    USB device fitness for purpose

    What's the make and model?

    Here

    Adapted from an old post (at least one of the links no longer works) …

    Sitecom USB 2.0 Dock CN-022
    Cerulian 10 port USB 2.0 top loading hub
    • circa 2011
    • Maplin Electronics code N14JB
    • System Information identifies the Cerulian N14JB as product 0x0608 from vendor 0x05e3 (Genesys Logic, Inc.)
    • Genesis Logic | USB Hub Product | Hub Controller … but I don't know whether what's in the N14JB is amongst that range of controllers.
    For me the 2005 device was and is more reliable than the 2011 device.

    I purchased the Cerulian after repeatedly failing to get information, from the manufacturer, for the hubs that Apple sold at the time. (Sometimes when I found trouble with a hub, Apple recommended trying one of the hubs that they knew to be good.)

    I guess a combination of the two.

    Certainly, some combinations of software will 'want more' from a hub than a clean installation of the operating system.

    A relatively extreme example

    Fitness for purpose of a USB 2.0 hub may be questioned with some approaches to ZFS on OS X. (In the MacZFS area: USB not supported; Issues with USB Drives. In the OpenZFS on OS X area: "… direct attached SATA, eSATA, Firewire, Thunderbolt, and Thunderbolt2 are better choices. …". And so on.) I used USB 2.0 with ZEVO.

    Without a hub

    Smart.
     
  25. richsad macrumors newbie

    Joined:
    Mar 15, 2014
    Location:
    Boston, MA area
    #25
    Belkin Hi-Speed USB 2.0 FSU237

    Quick update:

    The hub I am using is Belkin Hi-Speed USB 2.0 FSU237. It's been working great for years. I've had other hubs that haven't withstood the test of time.

    I plugged my time machine backup drive which is a Western Digital 1TB USB 2 drive directly into the USB port on the computer (no hub). I got the same error on sleep. It didn't happen every time, but it happened over half the time I tested. I tried several USB cables. The full description that Disk Utilities gives me for this drive is: WD Ext HDD 1021 Media

    It seems like I'm going to need to purchase Jettison. Since the problem is occurring even when the drive is plugged in directly, I'm not convinced that purchasing a new USB 3.0 hub would solve the problem. Because I use the drive for manual Time Machine backups it does get written to. Most of the other drives plugged in are used in a more read-only fashion.
     

Share This Page